summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-21 16:58:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 17:17:39 +0200
commit087aa3ad7e216ce466528ddc600ebffc2f6721aa (patch)
tree1ae60544fe43aac0117fb2cffabee95c3644e796 /dev-python/rfc3986
parentdev-python/pyldap: Version Bump (diff)
downloadgentoo-087aa3ad7e216ce466528ddc600ebffc2f6721aa.tar.gz
gentoo-087aa3ad7e216ce466528ddc600ebffc2f6721aa.tar.bz2
gentoo-087aa3ad7e216ce466528ddc600ebffc2f6721aa.zip
dev-python/rfc3986: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-0.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index c4886689af50..17c052a8d2c6 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1,2 +1,3 @@
DIST rfc3986-0.2.0.tar.gz 14522 SHA256 8a7b3f6cfdfb969c2e876513e87c30ebe1e4bdc9fae4a63c701eee88bbec9b22 SHA512 e16a7b690597e1d3bce0869e1bd7aecb60926b61da38e8b7170d920d73130512d4017426461d755792c2ea691b5c01ae8955e0b9818679e795b7338794b66d83 WHIRLPOOL 03bc5ca0d5e2cc06f8bc68029dfccfa71820512b546caeaddfe66f2233a9346d4ae3123c69efaee2b90258acdb3f0cde8f2ee84f4f29c0e1375f4fb9fc56effa
DIST rfc3986-0.2.2.tar.gz 17250 SHA256 b66238ee937485509326e0280eab4d8193df0e640936b99a6a181374dff97f7b SHA512 d6df82bce5de487a43cfd0e875d9e746e02f051fdfffa7b07564d025e77ed53ad02a09a837ba6c971b81019e091c694819de0e4ce43f19b4aa764ba21f70c054 WHIRLPOOL fc5b53681be16642947fa709232dc06e5643ddce6309bddb899abbdcac508060a84918f9b4b3b324c6de30dbd14669b92dea5ec34f39ddfb7a1289a7cf95a9ce
+DIST rfc3986-0.3.0.tar.gz 21421 SHA256 673715792042d9fb83571518c860074369b6d3610c8b48ac42f38fbc2722a48d SHA512 011999135fcaee82587342b2dc4e2203a783d82951589cddf49aaadf301f868b180216ad8e219059d9d4ca8425b2ecda8ead15c23baace01019d52b33782f5bb WHIRLPOOL e18cdc4f2e055cdcaa5ff41f83097970a542e37ccb94eab9b73ef32f7aff74b3497ed585ce31f473297a3a4e698416d688c85810a00b300d6b861466e3358c23
diff --git a/dev-python/rfc3986/rfc3986-0.3.0.ebuild b/dev-python/rfc3986/rfc3986-0.3.0.ebuild
new file mode 100644
index 000000000000..98afd20218e4
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986 https://github.com/sigmavirus24/rfc3986 https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}