summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 11:03:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 11:22:02 +0300
commit7e5bc4833cedb45946c644dbb79c9731a28ea185 (patch)
tree3a8669c522d9261d8f38a4467d460e94fc2fad39 /dev-python/requests_pkcs12
parentdev-python/cmd2: add 2.4.1 (diff)
downloadgentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.tar.gz
gentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.tar.bz2
gentoo-7e5bc4833cedb45946c644dbb79c9731a28ea185.zip
dev-python/requests_pkcs12: add 1.14
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests_pkcs12')
-rw-r--r--dev-python/requests_pkcs12/Manifest1
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/Manifest b/dev-python/requests_pkcs12/Manifest
index 62304f5b98e7..46515e45809d 100644
--- a/dev-python/requests_pkcs12/Manifest
+++ b/dev-python/requests_pkcs12/Manifest
@@ -1 +1,2 @@
DIST requests_pkcs12-1.10.tar.gz 4284 BLAKE2B 46ebbb00921f356ccf5793fe486d3e0d71b9b1688cb49d1c846c2ef808087bb51b71c18e89539946bf4b0c8d47df5ae7acda342b0e1293bf8a031eba5ba0ace5 SHA512 139d1b1ae740db7667bb079f955610ebbe6327dd6f050d59a0e6603f21a9fe0afde8dcb2ec666bc83f6b4205de05948dacf39bdec2d9f26bf3eaa7d6998f2fbb
+DIST requests_pkcs12-1.14.tar.gz 4896 BLAKE2B a8a3f0796092c66c210616ace20fb15cd82beb3ff3c0c0d1f2dccbd1ed7d62092a1faa69986e4f23d0b94af54f7f9b8819730f0c04c251fb751256dbd4c6bb56 SHA512 2d97b44b676c9e6e6eef127494d6c4a34179b8f69d8674ad9ecd9aa4171e5eb46a29a45ad5b5e8fe9facf234c1b7645fc5c87cef2b336beab941ce3e684c6d25
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
new file mode 100644
index 000000000000..24765222be05
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test" # no tests