summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 21:27:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 21:27:02 +0100
commit3a60709bc29042e80c7c51af393cc01bbb6ef542 (patch)
treead3e2d077a6734f6a358d87765556e6e90acbb85 /dev-python/requests
parentdev-python/pytz: Remove old (diff)
downloadgentoo-3a60709bc29042e80c7c51af393cc01bbb6ef542.tar.gz
gentoo-3a60709bc29042e80c7c51af393cc01bbb6ef542.tar.bz2
gentoo-3a60709bc29042e80c7c51af393cc01bbb6ef542.zip
dev-python/requests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/files/requests-2.28.1-fix-charsetnormalizer-assert.patch41
-rw-r--r--dev-python/requests/requests-2.28.1-r1.ebuild74
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 8c19f20cc4ad..8b5848be0464 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1,2 +1 @@
-DIST requests-2.28.1.tar.gz 109805 BLAKE2B 2106be5f9e1d9f1a22de5522b5d72084f91c2849e60e33b89b2411b76cae9b1f7faac34947f69c49480d001e9b77e4dce723ee939d51591882854d510db49b59 SHA512 c123ec07171c2c7c34e4173b97750adfa313b4312d91c0d58e4eb8750361604017e5b370c23ec886d2cbf704f9074ec5ad0fa9c2cd8e6f9521532adafff39d41
DIST requests-2.28.2.tar.gz 108206 BLAKE2B fe6c5d78e6abd36b7134c6e424b5a1c4052eba62b55a01b5842f289b94df3af039a5beba71374db563dd52ce42471d5e3650763b9324533ea6ab3bfd8013379b SHA512 3c4ba19a2bb6ba38a4118cf246db3855401869d54ee7ebd9bee40b435420381fb737d4c69768f2bd97914a30d66233c7058cec51aa629af0dff3b04e6f997a3d
diff --git a/dev-python/requests/files/requests-2.28.1-fix-charsetnormalizer-assert.patch b/dev-python/requests/files/requests-2.28.1-fix-charsetnormalizer-assert.patch
deleted file mode 100644
index 9975072c0c06..000000000000
--- a/dev-python/requests/files/requests-2.28.1-fix-charsetnormalizer-assert.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 23977ed77a..b679181bda 100755
---- a/setup.py
-+++ b/setup.py
-@@ -59,7 +59,7 @@ def run_tests(self):
- sys.exit()
-
- requires = [
-- "charset_normalizer>=2,<3",
-+ "charset_normalizer>=2,<4",
- "idna>=2.5,<4",
- "urllib3>=1.21.1,<1.27",
- "certifi>=2017.4.17",
-diff --git a/setup.cfg b/setup.cfg
-index 33af66eb15..0c167eb8c9 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -5,7 +5,7 @@ provides-extra =
- use_chardet_on_py3
- requires-dist =
- certifi>=2017.4.17
-- charset_normalizer>=2,<3
-+ charset_normalizer>=2,<4
- idna>=2.5,<4
- urllib3>=1.21.1,<1.27
-
-diff --git a/requests/__init__.py b/requests/__init__.py
-index 7ac8e297b8..5812c85d8a 100644
---- a/requests/__init__.py
-+++ b/requests/__init__.py
-@@ -80,8 +80,8 @@ def check_compatibility(urllib3_version, chardet_version, charset_normalizer_ver
- elif charset_normalizer_version:
- major, minor, patch = charset_normalizer_version.split(".")[:3]
- major, minor, patch = int(major), int(minor), int(patch)
-- # charset_normalizer >= 2.0.0 < 3.0.0
-- assert (2, 0, 0) <= (major, minor, patch) < (3, 0, 0)
-+ # charset_normalizer >= 2.0.0 < 4.0.0
-+ assert (2, 0, 0) <= (major, minor, patch) < (4, 0, 0)
- else:
- raise Exception("You need either charset_normalizer or chardet installed")
-
diff --git a/dev-python/requests/requests-2.28.1-r1.ebuild b/dev-python/requests/requests-2.28.1-r1.ebuild
deleted file mode 100644
index acd943c80725..000000000000
--- a/dev-python/requests/requests-2.28.1-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="
- https://requests.readthedocs.io/
- https://github.com/psf/requests/
- https://pypi.org/project/requests/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="socks5 test-rust"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- dev-python/charset_normalizer[${PYTHON_USEDEP}]
- <dev-python/idna-4[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.27[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
-"
-
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- test-rust? (
- dev-python/trustme[${PYTHON_USEDEP}]
- )
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.28.0-drop-dependency-warnings.patch
- # https://github.com/psf/requests/pull/6261
- "${FILESDIR}"/${PN}-2.28.1-fix-charsetnormalizer-assert.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet (doctests)
- requests/__init__.py::requests
- requests/api.py::requests.api.request
- requests/models.py::requests.models.PreparedRequest
- requests/sessions.py::requests.sessions.Session
- # require IPv4 interface in 10.* range
- tests/test_requests.py::TestTimeout::test_connect_timeout
- tests/test_requests.py::TestTimeout::test_total_timeout_connect
- # TODO: openssl?
- tests/test_requests.py::TestRequests::test_pyopenssl_redirect
- )
-
- if ! has_version "dev-python/trustme[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/test_requests.py::TestRequests::test_https_warnings
- )
- fi
-
- epytest
-}