summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 23:51:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 23:51:19 +0100
commit5b9c595ed61272d9c856e149bbfce80f0d6f905c (patch)
tree4224ef2d78bd4687de1aca5dc1567980bceb885e /dev-python/requests-cache
parentdev-python/Faker: Bump to 13.0.0 (diff)
downloadgentoo-5b9c595ed61272d9c856e149bbfce80f0d6f905c.tar.gz
gentoo-5b9c595ed61272d9c856e149bbfce80f0d6f905c.tar.bz2
gentoo-5b9c595ed61272d9c856e149bbfce80f0d6f905c.zip
dev-python/requests-cache: Bump to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 723c12ffa846..c3c1b2a057ed 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1 +1,2 @@
DIST requests-cache-0.9.1.gh.tar.gz 1539483 BLAKE2B 9adb6710cda7fb6ae9dba9b6ce57351b9817419f7108da328f4ac206534c6c5453d79592ecbe1108d3d5d78862ed109630fdce518025a42b1db101c906253d16 SHA512 829488f68f10be8f84203d488d5dab68c477d02bc4419b49b38851693f2bd1d0ec0b86bc5d953b951b9c7d4372b2bc179f096014f69eb6356f87a2b1d025d3a0
+DIST requests-cache-0.9.2.gh.tar.gz 1539753 BLAKE2B a49932b961486e5af1681d0094c599e12c12dc340b1631b9e0a8ab19268f04005ba56f6bb2c8759268e8cea866e94a1b3f59e1e7d9229aa257f3bb2daab8a187 SHA512 449dcd5924388cd8a02114e2588dfe50f0289be07ec3eaa06388298c959e69e891e51793a18ba2766d7a0ff866355e3d4950ebcd04b2349a146d342e11eb41bd
diff --git a/dev-python/requests-cache/requests-cache-0.9.2.ebuild b/dev-python/requests-cache/requests-cache-0.9.2.ebuild
new file mode 100644
index 000000000000..5b0486352cb2
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.9.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cattrs[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+ local EPYTEST_DESELECT=(
+ # Requires Internet access
+ tests/integration/test_compat.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "redis backend" "dev-python/redis-py"
+ optfeature "MongoDB backend" "dev-python/pymongo"
+
+ optfeature "JSON serialization" "dev-python/ujson"
+ optfeature "YAML serialization" "dev-python/pyyaml"
+ optfeature "signing serialized data" "dev-python/itsdangerous"
+}