summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-28 21:56:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-28 22:01:30 +0300
commit5846c6b27f4c006e8210f1833cb2314d8ef33af3 (patch)
tree7647e86801d72da13ebd1d3bd40568ca3221a447 /dev-python/redis
parentapp-admin/sysstat: Stabilize 12.6.2-r1 sparc, #907044 (diff)
downloadgentoo-5846c6b27f4c006e8210f1833cb2314d8ef33af3.tar.gz
gentoo-5846c6b27f4c006e8210f1833cb2314d8ef33af3.tar.bz2
gentoo-5846c6b27f4c006e8210f1833cb2314d8ef33af3.zip
dev-python/redis: enable py3.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/redis-4.5.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/redis/redis-4.5.5.ebuild b/dev-python/redis/redis-4.5.5.ebuild
index 37fbc3edbe6d..721f1f890ad5 100644
--- a/dev-python/redis/redis-4.5.5.ebuild
+++ b/dev-python/redis/redis-4.5.5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -47,6 +47,8 @@ python_test() {
tests/test_commands.py::TestRedisCommands::test_acl_list
# redis-7 different return
tests/test_commands.py::TestRedisCommands::test_xautoclaim
+ # hangs on all targets
+ tests/test_asyncio/test_cwe_404.py::test_standalone
)
# TODO: try to run more servers?