summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-10 06:16:41 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-10 06:31:00 +0100
commit1de35b135ef22082e930422e3327074825cdce38 (patch)
tree33761c0e384501e752616a3a82043d61bc98c3b2 /dev-python/quart-trio
parentdev-python/sh: Bump to 2.2.1 (diff)
downloadgentoo-1de35b135ef22082e930422e3327074825cdce38.tar.gz
gentoo-1de35b135ef22082e930422e3327074825cdce38.tar.bz2
gentoo-1de35b135ef22082e930422e3327074825cdce38.zip
dev-python/quart-trio: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quart-trio')
-rw-r--r--dev-python/quart-trio/Manifest1
-rw-r--r--dev-python/quart-trio/quart-trio-0.12.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/quart-trio/Manifest b/dev-python/quart-trio/Manifest
index ca8de06ec426..d8741725361f 100644
--- a/dev-python/quart-trio/Manifest
+++ b/dev-python/quart-trio/Manifest
@@ -1 +1,2 @@
DIST quart-trio-0.11.1.gh.tar.gz 18568 BLAKE2B faabf4204a82dcc70e41d1d1ec7171c89386f2e40979c20501890d9bc27eb2af693bc791a9015a9c4c676a5e25ec69dc4975a0cd09987cd14f699a04442d54da SHA512 8ea20c36c772eff3e2b0a83a4c325cd223c19b3d7e1e51e7378897bd11479db2c8015d2e8c4713721070fc413f42b19f844a3966a0d06d299439cf514b0b3291
+DIST quart_trio-0.12.0.tar.gz 14979 BLAKE2B 7a7ffaba59e6984001941c1c54cfab189434366ab1b56d6509567c79560d916e2a5f0c81e8f23e17462de17d012d77eda3803cc8828a5378b3b92c1bab00e475 SHA512 70b1f2406185b020f999cb335c2c13599faf9c36c69f8adc437fbb846158f659e8d6527199083f9674e75c99bcd10dbf228dbd62ca7c5614b471c462b22227ee
diff --git a/dev-python/quart-trio/quart-trio-0.12.0.ebuild b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
new file mode 100644
index 000000000000..53640fe9bc8b
--- /dev/null
+++ b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Quart extension to provide trio support"
+HOMEPAGE="
+ https://github.com/pgjones/quart-trio/
+ https://pypi.org/project/quart-trio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/quart-0.19[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p trio
+}