summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-22 18:01:57 +0000
committerSam James <sam@gentoo.org>2023-02-22 18:01:59 +0000
commite7185127883dd217b3246501de6d677c1971e154 (patch)
treec47b96a00776d3fb57ace23be8060655b0528092 /dev-python/qiskit-terra
parentsys-apps/uutils-coreutils: install multicall binary & use hardlinks (diff)
downloadgentoo-e7185127883dd217b3246501de6d677c1971e154.tar.gz
gentoo-e7185127883dd217b3246501de6d677c1971e154.tar.bz2
gentoo-e7185127883dd217b3246501de6d677c1971e154.zip
dev-python/qiskit-terra: only run Python test suite, not random
Upstream run the randomised one in a separate CI job and it doesn't feel suitable for ebuilds. This fixes some but not all of the hangs we've seen in the ebuild. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/qiskit-terra')
-rw-r--r--dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild b/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild
index 3fcd499d482c..2c91a4de0a12 100644
--- a/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild
+++ b/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild
@@ -156,5 +156,7 @@ python_test() {
)
rm -rf qiskit || die
- epytest -p xdist -n "$(makeopts_jobs)"
+ # Run the Python test suite rather than everything under test/ which
+ # includes the 'randomized' suite. Upstream run that in a separate CI job.
+ epytest -p xdist -n "$(makeopts_jobs)" test/python
}