summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 11:41:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 12:03:55 +0200
commitd6a667c6c19b213faf5db3af86e1cec889da9552 (patch)
tree1ad87e71d300e62313084de2e6561c01b069e52c /dev-python/pyyaml
parentdev-python/cython: Bump to 0.29.28_p20220503 snapshot (diff)
downloadgentoo-d6a667c6c19b213faf5db3af86e1cec889da9552.tar.gz
gentoo-d6a667c6c19b213faf5db3af86e1cec889da9552.tar.bz2
gentoo-d6a667c6c19b213faf5db3af86e1cec889da9552.zip
dev-python/pyyaml: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/pyyaml-6.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-6.0-r1.ebuild b/dev-python/pyyaml/pyyaml-6.0-r1.ebuild
new file mode 100644
index 000000000000..2925130948e7
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-6.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="
+ https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml/
+"
+SRC_URI="
+ https://github.com/yaml/pyyaml/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+DEPEND="
+ dev-libs/libyaml:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+src_configure() {
+ export PYYAML_FORCE_CYTHON=1
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}