summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-14 09:37:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-14 09:51:07 +0200
commit3b6e64f437f4e7b7a03609314c62bd6cb5657325 (patch)
tree7d2588213d66a0c39d5b1fe3790509eef17c97fd /dev-python/pyyaml
parentdev-python/setuptools: Bump to 58.2.0 (diff)
downloadgentoo-3b6e64f437f4e7b7a03609314c62bd6cb5657325.tar.gz
gentoo-3b6e64f437f4e7b7a03609314c62bd6cb5657325.tar.bz2
gentoo-3b6e64f437f4e7b7a03609314c62bd6cb5657325.zip
dev-python/pyyaml: Bump to 6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/Manifest1
-rw-r--r--dev-python/pyyaml/pyyaml-6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
index 3826a56adb87..c1db8ec96f27 100644
--- a/dev-python/pyyaml/Manifest
+++ b/dev-python/pyyaml/Manifest
@@ -1,2 +1,3 @@
DIST pyyaml-5.3.1.gh.tar.gz 168044 BLAKE2B 2acc62ecc7448925eb340c2555001c8a74bd883d720b992d6deaea890b4eac435e4ae02eb129db3a6778c0be21a231fa9d96ee8ae59a4a39bc49961e5fb0d6ab SHA512 27d97e8493c7660c7c0c471e20a8aa46c85431e4559a98bcbdafc2bd89a67fd04c6f2090e54ff6b206c868b33635ef8be68070a4c25d17a25c97fd5ad3549556
DIST pyyaml-5.4.1.gh.tar.gz 173319 BLAKE2B b81cdec32588a419840dd536a2d8addb41eec3e20897f6c464a00a5badb4d6eed9b34b4f95146695187e7d9bcf2d03b81e884290c6dc47927be6192dfdb21eab SHA512 691e54fd9ca01fdc0dcb7de03ddd1970614d92a716c2437032999f9001f90a2ebbcc195a49bfdbe54da0f7a63178c83b02b05b18b5b1024127013f004d1f5997
+DIST pyyaml-6.0.gh.tar.gz 119855 BLAKE2B 286678ac81f2e6c252d285d2f98dab98894787e3aa164a29a697986f56200c7b71b0a768edf6d50e61065efcd054078673270872162a4975409928d7dd67aacc SHA512 cbcacc3560a035e2082867e93a9733f8660ea4c7f60573d07642f33a5453dcdc88d67299c3bcb97c27b843202a45d40de7444eb5e815bd4955129c9fc8ae04ad
diff --git a/dev-python/pyyaml/pyyaml-6.0.ebuild b/dev-python/pyyaml/pyyaml-6.0.ebuild
new file mode 100644
index 000000000000..0448b8d0f038
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="
+ https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml/"
+SRC_URI="https://github.com/yaml/pyyaml/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="dev-libs/libyaml:="
+DEPEND="${RDEPEND}"
+# bundled distutils is broken w/ pypy3 in setuptools < 58
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/setuptools-58.2.0[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+
+distutils_enable_tests setup.py
+
+src_configure() {
+ export PYYAML_FORCE_CYTHON=1
+ DISTUTILS_ARGS=(
+ # --without-libyaml doesn't disable trying to use libyaml
+ # and results in automagic dep; --with-libyaml guarantees that
+ # the build fails if the C extension fails to build
+ --with-libyaml
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}