summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 11:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 11:21:40 +0200
commit5dae13489de16db4005964ba5906b0710baa0abe (patch)
treef967b555229bce5e15d680411ee6936990d90935 /dev-python/pywlroots
parentdev-python/pywlroots: Add missing cffi dep to 0.16.4 (diff)
downloadgentoo-5dae13489de16db4005964ba5906b0710baa0abe.tar.gz
gentoo-5dae13489de16db4005964ba5906b0710baa0abe.tar.bz2
gentoo-5dae13489de16db4005964ba5906b0710baa0abe.zip
dev-python/pywlroots: Replace virtual/python-cffi dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywlroots')
-rw-r--r--dev-python/pywlroots/pywlroots-0.15.24-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pywlroots/pywlroots-0.15.24-r1.ebuild b/dev-python/pywlroots/pywlroots-0.15.24-r1.ebuild
index 5a40f586518b..dc67164d0571 100644
--- a/dev-python/pywlroots/pywlroots-0.15.24-r1.ebuild
+++ b/dev-python/pywlroots/pywlroots-0.15.24-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -24,10 +24,12 @@ KEYWORDS="amd64 ~riscv ~x86"
# See README for wlroots dep
RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
>=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
>=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
=gui-libs/wlroots-$(ver_cut 1-2)*:=
- virtual/python-cffi[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"