summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-08 19:04:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-08 19:47:55 +0200
commit36ef46a30b8e6ef347d3d9faa9da6bbc17ba281a (patch)
tree7cfdac6f4fb0ba756b2ee670f7991129856b4ba8 /dev-python/pywlroots
parentdev-python/flask-paginate: Bump to 2023.10.8 (diff)
downloadgentoo-36ef46a30b8e6ef347d3d9faa9da6bbc17ba281a.tar.gz
gentoo-36ef46a30b8e6ef347d3d9faa9da6bbc17ba281a.tar.bz2
gentoo-36ef46a30b8e6ef347d3d9faa9da6bbc17ba281a.zip
dev-python/pywlroots: Bump to 0.16.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywlroots')
-rw-r--r--dev-python/pywlroots/Manifest1
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.6.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
index 74f31e4c7194..22fd5902ef0c 100644
--- a/dev-python/pywlroots/Manifest
+++ b/dev-python/pywlroots/Manifest
@@ -1,3 +1,4 @@
DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1feec20e2380357060a850dab417b3fb1fccb4a9e6cc6564d2b7f124bf4fc454789549267e9036b0b4559e5fcd4c6f06196 SHA512 b29b76cf18a65b2ef19d15ecf018a9ba44119d60ee61435967d17f06d5f7544d2117f2e9a81574734c71591a237b00c8584a5cc6d6adb928f39f11170f21ee94
DIST pywlroots-0.16.4.tar.gz 91198 BLAKE2B eb1fd95dc16cb1c4b969d4c69627c344d03f6ec9d3651c2dcfa3067afbde979924bb88b4cb39c8a264da08392a641a73a45ee79a4e76f1d475d9afc2c5cc310c SHA512 9f10b510f0b034448f65658f5b234c0d152440c0ce133918dbb97ff2c8f3a9ee2ee19011f1fd931713da798c8dce55bf485c559e18f0468c19702996d0f29cd8
DIST pywlroots-0.16.5.tar.gz 91626 BLAKE2B e91acaf92b56e67e42465379018f154d6f1a455d5f8fa7319d8a50a569f1e424026501b2c648f4a976a7961939eeadb52696aaa87ee4b644e4a2e3ebe6c06862 SHA512 6336150dabd3847f818baa65124519c3935a15a9eb360a93e6be7ad217283e1f55f4cc299d692eaefe2fc7d11d4edbdaa7f946498b16403e7012f99d91c4a200
+DIST pywlroots-0.16.6.tar.gz 91625 BLAKE2B d8784add8266958745fb9d9ca25d47b3bd52957cef22a70b30b051aa53996a8b870d436a44c75f8a16fd7346b7ff2c00a70eb86b376294f3928ecd8807b6646e SHA512 31588ebccbd269e45374cd42067738c23bd76ea8a0304d17aff9da33c7686a5fb9c83a676575f0ad034afd2827cb8bea7eb9334e96badcc83ffede56fbf75a1b
diff --git a/dev-python/pywlroots/pywlroots-0.16.6.ebuild b/dev-python/pywlroots/pywlroots-0.16.6.ebuild
new file mode 100644
index 000000000000..15d6d590ef3f
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.16.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots/
+ https://pypi.org/project/pywlroots/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# See README for wlroots dep
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+ x11-base/xwayland
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf wlroots || die
+ epytest
+}