summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-06-03 16:55:54 -0400
committerMike Gilbert <floppym@gentoo.org>2017-06-03 16:57:17 -0400
commita2a2f4bb2bb5454001bf2c085aa05e336913a337 (patch)
treee3735811e91398dcd9a59ddf6f41eb85de8f199a /dev-python/python3-openid
parentdev-perl/DateTime-Format-W3CDTF: Cleanup old re bug #614962 (diff)
downloadgentoo-a2a2f4bb2bb5454001bf2c085aa05e336913a337.tar.gz
gentoo-a2a2f4bb2bb5454001bf2c085aa05e336913a337.tar.bz2
gentoo-a2a2f4bb2bb5454001bf2c085aa05e336913a337.zip
dev-python/python3-openid: bump to 3.1.0
Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'dev-python/python3-openid')
-rw-r--r--dev-python/python3-openid/Manifest1
-rw-r--r--dev-python/python3-openid/python3-openid-3.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python3-openid/Manifest b/dev-python/python3-openid/Manifest
index 86efff64b506..3dd7d84911a2 100644
--- a/dev-python/python3-openid/Manifest
+++ b/dev-python/python3-openid/Manifest
@@ -1 +1,2 @@
DIST python3-openid-3.0.4_p1.tar.gz 306465 SHA256 eb78cb2288805ee1c51eeaa8941c61be796ac1126e1ca0a2c49dc7582b0c0407 SHA512 6e710dc47c3c1d4f31937b8a4dcf546cdb06128ffddbc3b2e2a2a9e09a8a3a7122326ba2137a92269f58a29f1b264c2e942610098f91f237d45f5ff0887faea0 WHIRLPOOL 8812d4fd0c0ffd3e40f4f8414463f05cf62b37d388039a5287ac412c452a8e7cb142accafdfbd9e32d36cde3d4a6d96954742b542fdc92168d31574de185c152
+DIST python3-openid-3.1.0.tar.gz 299326 SHA256 628d365d687e12da12d02c6691170f4451db28d6d68d050007e4a40065868502 SHA512 9c96efd16191ddb6ddb12c4885a2cce523244d04e70f9418144d0124ef142fd7b6578cd2a01e949995d7dedf0b96cbb3b17d1d3a29db5da8934f7fa875ad8e9c WHIRLPOOL 1b46810f625d0e5a3018b2dd2c1df938bb3df41c3316d04910d1e3ed24e747e0066829782bd978f92a20291a02f1562beb40e498fe1d3f928828cc2b708ce199
diff --git a/dev-python/python3-openid/python3-openid-3.1.0.ebuild b/dev-python/python3-openid/python3-openid-3.1.0.ebuild
new file mode 100644
index 000000000000..934d5daa1464
--- /dev/null
+++ b/dev-python/python3-openid/python3-openid-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 port of the python-openid library"
+HOMEPAGE="https://github.com/necaris/python3-openid https://pypi.python.org/pypi/python3-openid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/defusedxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ ${EPYTHON} -m unittest -v openid.test.test_suite
+}