summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-07 09:56:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-07 10:00:31 +0100
commitb8d5abbec53d2580f65b343c9708838267e75063 (patch)
tree707a6621d3807d752116946650d6ac2d663fdf57 /dev-python/python-stdnum
parentdev-python/apispec: Add python@ as co-maint (diff)
downloadgentoo-b8d5abbec53d2580f65b343c9708838267e75063.tar.gz
gentoo-b8d5abbec53d2580f65b343c9708838267e75063.tar.bz2
gentoo-b8d5abbec53d2580f65b343c9708838267e75063.zip
dev-python/python-stdnum: Bump to 1.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.16.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 253bf45853f9..81fdafea5347 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,2 +1,3 @@
DIST python-stdnum-1.14.tar.gz 953637 BLAKE2B 5772fd2284dc9c255b544c6f0d1f4d1ebbaa48547cf1ba9aafb082a4d649ce90574444b298a333c9fbac5e232d2ea144f2e5bbd817fb6e7b78ea66081ed871b2 SHA512 d17643a2e4d8efc5f554c9c114399802e6dae0ff60b6ab0e32ebf6ece7c87a96287dd1c2e68e4fcd97f8ab475a267de5dad41d726470690255a2a0aeddedbb8e
DIST python-stdnum-1.15.tar.gz 1037630 BLAKE2B 7d4bc086a5c0e272b7c55ed5bead9561375b6410b286c6d1d78e49dfc1473a9021646fbd363cfa532bc3eb1a54284b253f46ab28f60d2d411efa0992772a02a0 SHA512 e6f1d921e8ce64a11f9c5572e7eabc27bd7c71c34017fb795c45fa585701fcc78ff81c15b1a9bd48b8d9975e1fbc354b3923942c6f81e8fe4dfb8f611e3ab9cc
+DIST python-stdnum-1.16.tar.gz 1039599 BLAKE2B 98197fca412371757b7e7ec242d30d5fc43352b9eba7677aeb3a475dbe7a379c4f88797192b8e5de97493186562d1d21347703643be7798316e22f28c6a144bf SHA512 29ad92a8d1d3267c56e3d128700611cbfe3bc7a27a1420bfe62851f110f3f23b1d8927771588ef043aba366913bf7a5b0eb72896ee50343f3adf72cdb071415b
diff --git a/dev-python/python-stdnum/python-stdnum-1.16.ebuild b/dev-python/python-stdnum/python-stdnum-1.16.ebuild
new file mode 100644
index 000000000000..7ee9a4124ff7
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+DOCS=( ChangeLog NEWS README )
+
+distutils_enable_tests nose