summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-01-25 00:25:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-02-01 21:17:55 +0200
commit5f41a654c60e16f05d6bc8ca94c8ce01efbdbdcb (patch)
treec6aa77e048d43f1f6e2dfac1d7c1f65b7eeb9675 /dev-python/python-markdown-math
parentpackage.mask: Last rite dev-python/berkeleydb (diff)
downloadgentoo-5f41a654c60e16f05d6bc8ca94c8ce01efbdbdcb.tar.gz
gentoo-5f41a654c60e16f05d6bc8ca94c8ce01efbdbdcb.tar.bz2
gentoo-5f41a654c60e16f05d6bc8ca94c8ce01efbdbdcb.zip
dev-python/python-markdown-math: 0.8-r1, bump EAPI8, add Python3.11
Switch to unittest Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/29253 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-markdown-math')
-rw-r--r--dev-python/python-markdown-math/python-markdown-math-0.8-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-markdown-math/python-markdown-math-0.8-r1.ebuild b/dev-python/python-markdown-math/python-markdown-math-0.8-r1.ebuild
new file mode 100644
index 000000000000..d38d5ee35c83
--- /dev/null
+++ b/dev-python/python-markdown-math/python-markdown-math-0.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Math extension for Python-Markdown"
+HOMEPAGE="
+ https://github.com/mitya57/python-markdown-math/
+ https://pypi.org/project/python-markdown-math/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.3.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest