summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2019-12-02 19:02:15 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-03 19:47:38 -0500
commit298230439c1db60e8972717cf83678552764255d (patch)
treec5099f4d4cf532618bcbbd51960bd26fed021178 /dev-python/python-markdown-math
parentsci-libs/indilib: Drop 1.8.2 (r0) (diff)
downloadgentoo-298230439c1db60e8972717cf83678552764255d.tar.gz
gentoo-298230439c1db60e8972717cf83678552764255d.tar.bz2
gentoo-298230439c1db60e8972717cf83678552764255d.zip
dev-python/python-markdown-math: Add missing dep to markdown
Closes: https://bugs.gentoo.org/701190 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/python-markdown-math')
-rw-r--r--dev-python/python-markdown-math/python-markdown-math-0.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-markdown-math/python-markdown-math-0.6-r1.ebuild b/dev-python/python-markdown-math/python-markdown-math-0.6-r1.ebuild
new file mode 100644
index 000000000000..58867491362b
--- /dev/null
+++ b/dev-python/python-markdown-math/python-markdown-math-0.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+
+DESCRIPTION="Math extension for Python-Markdown"
+HOMEPAGE="https://github.com/mitya57/python-markdown-math"
+
+if [[ ${PV} == **9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mitya57/python-markdown-math.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests for python2.7 ran fine even with dev-python/markdown-2.6.5,
+# but python3.7 is only supported from 3.x onwards.
+DEPEND="
+ >=dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+python_test(){
+ esetup.py test
+}