summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2016-07-23 17:57:26 +0100
committerMike Gilbert <floppym@gentoo.org>2016-07-31 21:01:03 -0400
commita0290fa33d84293e69611a4995703574dae6453f (patch)
treedd207b3cee382296029eb67ae860ab7ebdb5e7b8 /dev-python/python-docs/python-docs-2.7.12.ebuild
parentnet-analyzer/netdata: set fcaps on /usr/libexec/netdata/plugins.d/apps.plugin (diff)
downloadgentoo-a0290fa33d84293e69611a4995703574dae6453f.tar.gz
gentoo-a0290fa33d84293e69611a4995703574dae6453f.tar.bz2
gentoo-a0290fa33d84293e69611a4995703574dae6453f.zip
dev-python/python-docs: Bump to 2.7.12 and EAPI 6
New https SRC_URI and HOMEPAGE Closes: https://github.com/gentoo/gentoo/pull/1944
Diffstat (limited to 'dev-python/python-docs/python-docs-2.7.12.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.7.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.7.12.ebuild b/dev-python/python-docs/python-docs-2.7.12.ebuild
new file mode 100644
index 000000000000..0ee6acfd1f61
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.7.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="2.7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}" || die
+ doenvd "60python-docs-${SLOT}"
+}