summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-27 13:57:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-27 14:03:19 +0200
commit2448ab6eac3a0f4f741b80d206ea8d8d72c93fc1 (patch)
tree7b2cea14fac1e8a6cbca724481a707d83705486f /dev-python/python-distutils-extra
parentnet-misc/icaclient: Removed old (diff)
downloadgentoo-2448ab6eac3a0f4f741b80d206ea8d8d72c93fc1.tar.gz
gentoo-2448ab6eac3a0f4f741b80d206ea8d8d72c93fc1.tar.bz2
gentoo-2448ab6eac3a0f4f741b80d206ea8d8d72c93fc1.zip
dev-python/python-distutils-extra: Bump to 2.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest1
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.44.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index 5de44833a32a..b23c1e120cd4 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1 +1,2 @@
+DIST python-distutils-extra-2.44.tar.bz2 37687 BLAKE2B 3d7e3ad277440bfb6fbade8b890b95aad37589700b69a26ec9a5c30e97491871bc8c8f82b540131859d2ce82cebd3758f29ca510abe28046ffcaa0e7240fad3e SHA512 517222b4e34efba730db53ffeee8b8c8d96bd9d1b6044e6ca84c0f2c1d5c0e044240b899d460c50295615c94c513f7e57db3e34e5db6588a01ec92a73999f822
DIST python-distutils-extra_2.42.tar.xz 37996 BLAKE2B dee4cc950bb34027b60dcf58e173bae502a7090062e3c2218fd2ec562d6350f5872ed5c0865b89f1463bd35be0f365f23e05bb0220f70a944181af40df42ee60 SHA512 ff0df0a25a29504bec89970dbbf24d0b618e9f2d5d07a037f67778b86c92e880eafee86dd102b4ada4f280abd3102de9f4a4e47dbc68c1eaaa05fb492cbbae29
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.44.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.44.ebuild
new file mode 100644
index 000000000000..c279a3684ff1
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.44.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra
+ https://launchpad.net/python-distutils-extra"
+SRC_URI="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+DOCS=( doc/{README,FAQ} )
+
+src_prepare() {
+ sed -e 's:test_requires_provides:_&:' \
+ -i test/auto.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ unset PYTHONDONTWRITEBYTECODE
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}