summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 18:20:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-27 19:13:08 +0200
commit35574821f71645c5afd507fd1cca6e3eca456acb (patch)
tree346395409190dcf4c9dc1ddbc812088ac010cb5c /dev-python/pytest-virtualenv
parentdev-python/pytest-shutil: Enable py3.12, fix tests (diff)
downloadgentoo-35574821f71645c5afd507fd1cca6e3eca456acb.tar.gz
gentoo-35574821f71645c5afd507fd1cca6e3eca456acb.tar.bz2
gentoo-35574821f71645c5afd507fd1cca6e3eca456acb.zip
dev-python/pytest-virtualenv: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-virtualenv')
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild
index 4fb299661f81..d62946045aa1 100644
--- a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -23,6 +23,7 @@ RDEPEND="
dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
dev-python/pytest-shutil[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
"
BDEPEND="
@@ -33,3 +34,16 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # assumes setuptools is installed inside virtualenv
+ # https://github.com/man-group/pytest-plugins/issues/220
+ tests/integration/test_tmpvirtualenv.py::test_installed_packages
+ )
+ fi
+
+ epytest
+}