summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 06:05:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 06:05:58 +0200
commit5930bbc6e73f0d3c9cecf4afb743831fd7249bfa (patch)
treef2447594f4c5b309bd1a769514edeedd5a07960a /dev-python/pytest-subtests
parentnet-nntp/nzbget: add 24.1 from new nzbget.com fork, #911617 (diff)
downloadgentoo-5930bbc6e73f0d3c9cecf4afb743831fd7249bfa.tar.gz
gentoo-5930bbc6e73f0d3c9cecf4afb743831fd7249bfa.tar.bz2
gentoo-5930bbc6e73f0d3c9cecf4afb743831fd7249bfa.zip
dev-python/pytest-subtests: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.13.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index e66bdfa70dd7..f386fef2a6a7 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,2 +1,3 @@
DIST pytest-subtests-0.12.1.tar.gz 15303 BLAKE2B 68ce29fd067836cb32b43f260c98b0a8d1827a1bf6f3f61bc98eb69a5259dad725379bece5fe745e86561cab7e58042aff7da51d39e99fd09bbf0127d04d8cca SHA512 5eb4ff950171f8e008b3879453b55bab1ebc82ec60ca4da839158ad6e195c03f1a5d6b6ce2ac263a3ecaa2f684955e4fcc7abf5e429de9ffd898586b758e6cd4
DIST pytest_subtests-0.13.0.tar.gz 15842 BLAKE2B 8ca2b7eb9983bc8d07d2e1eff281b0047b8a8002eff7aa916e58927522eb390c2e6fd8f788738d5a5ae725bb93cd7f8f4e99eca0270d76b64a2d55f2f3c37d8f SHA512 0cff25633782e898594fab2de7078ef0d3983d5fd5ec35179e8016905f2d795024fd7c430aad42c3889f4c3f28947a4bdb93de7fad2dd9fec2d721c0fd51d323
+DIST pytest_subtests-0.13.1.tar.gz 15936 BLAKE2B 6301c0dae6eccd9f20acf6c08e0b1b77c7e80a64e4558628cc85e0d6c202d0b2bb0d7be27f930d7bf68ab8c4c2076e7fe68ab24b9b45cb22fbb3a4b31fd7b4e7 SHA512 c1c92a7a608710fd75a3a67cfd620ec257d7b1fa191fc4788a747ffebdf3973dde9407ed85e1842f15947558f6ec7c15e5c13ad84ce59489398386d6578f1caf
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.13.1.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.13.1.ebuild
new file mode 100644
index 000000000000..477c42560e40
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.13.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_subtests.plugin
+ epytest
+}