summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 04:50:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:15:08 +0200
commit577b79ddc0b1a5523bebd3cdc1da341dccf90f74 (patch)
tree322221daf4eb07235512b9c34507411a65b79fa4 /dev-python/pytest-rerunfailures
parentdev-python/pydantic: Enable py3.12 on 2.0.2 (diff)
downloadgentoo-577b79ddc0b1a5523bebd3cdc1da341dccf90f74.tar.gz
gentoo-577b79ddc0b1a5523bebd3cdc1da341dccf90f74.tar.bz2
gentoo-577b79ddc0b1a5523bebd3cdc1da341dccf90f74.zip
dev-python/pytest-rerunfailures: Bump to 12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-12.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 60ac0faef666..3625d23e8b08 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1 +1,2 @@
DIST pytest-rerunfailures-11.1.2.tar.gz 17234 BLAKE2B c497fee173f09de42d605d092336105e7144aafcdcfe6cdfbe3df65e09c3ab5cf0bc2d42746662f792c832ac25538f3cd81dc97d6e01201b14b480cb0e2d3a46 SHA512 309a0d180a996ddb5d6eb0833e6abd107887bc17ca3003a2b02bbaf5a4cbd63012618ee293a2a80623ca327b46ce7a5cd53bb341de75e5670a62b84e7ce5f0bc
+DIST pytest-rerunfailures-12.0.tar.gz 21154 BLAKE2B 3de39a8b92858bd90b312fca1c5f2e5ad790e12277f118bf18182b6192edf14dd160070bfe31ce981dc7ba41e0d0e2509ea80793c35c1856afdcfb5272ca55cc SHA512 2e6787ec8b420344eb1f7175b0f9e7f8a2f3cc3fd59ebf0c49128b39dc887200bd497e1d73a59311d072456e34126a1829324a4d86f86e5c01916940383c8fd4
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-12.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-12.0.ebuild
new file mode 100644
index 000000000000..c6263b8ee63e
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}