summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-22 19:56:02 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-22 19:59:02 +0200
commit2a617d49e510be4387af3d6955652d67c9f51b3a (patch)
treedbbb927f321a4f27789cdd450bdb3a67d42ec5dd /dev-python/pytest-qt
parentdev-python/pytest-qt: add version 4.0.2 (diff)
downloadgentoo-2a617d49e510be4387af3d6955652d67c9f51b3a.tar.gz
gentoo-2a617d49e510be4387af3d6955652d67c9f51b3a.tar.bz2
gentoo-2a617d49e510be4387af3d6955652d67c9f51b3a.zip
dev-python/pytest-qt: clean up 4.0.0 and 4.0.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest2
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.0.0.ebuild59
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.0.1.ebuild59
3 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index 0d187ea30ef4..f14eaa57756e 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1,4 +1,2 @@
DIST pytest-qt-3.3.0.tar.gz 113439 BLAKE2B 1eb486d2d44825058577306ed3b9ade34e6cbad0d90038fe314114bb22c82ae069c9fe66c170591de6c97bad99f5f9e0021c8b3dc38c858b8293a22c448bed74 SHA512 8b3ce7b62621c55fb319966b162cb60663c5ef290f34e62e6a9329e67f530c2bde1329ae0b045b15c99ae14f5f6a5fef9ee930475fa700922c50ee725adf7983
-DIST pytest-qt-4.0.0.tar.gz 113333 BLAKE2B 69c2c8c823b55c44150c7beb0754e90866c7659912dbc0d99ee29904b0a20eadf26939709a5d120d0b95e23bcb99310415932e87934ae84571c55e3ffd07c284 SHA512 cfdde2e82b42979313d96f9a14bdafea0d4d5d5b64b4785ac73b74e36bfb892ab7b5ec6eb1c4e540ec00ccec6739e8bd9a3ffb610f204f6cfe97061f57a3971a
-DIST pytest-qt-4.0.1.tar.gz 113473 BLAKE2B b77438ea2e6f71566daa50628d481671bc5ece0cffe2c67d689e780274884d70d94d70305c92775e5d9bba7fe09431ce7116aa5823234675237149726178ba43 SHA512 4f6d9057d5c6ebf439d0f69a341b3d7a4297e3eea251f85c82cf5ecc7aca1419b7a2ab0e846852661a0a2236af6225518b3ae691bb014fb56dbc1d39106db4cc
DIST pytest-qt-4.0.2.tar.gz 113466 BLAKE2B 73ba6571958f3f4cd76c3e891eaa014d464b94a7965afac6cee5b43bafdc63d4d640f84c7bfa1666146ab5139f79c760bd9f5a2a44f788b6384df200ac48ad0d SHA512 7f59c499e1395460c2ff20a969cec16ca104f742c648faa0d7eb1528c04d8ee52c04c52798478bc01c5467bee33d3389b141424491ba5442f9df4e82f0dff173
diff --git a/dev-python/pytest-qt/pytest-qt-4.0.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.0.0.ebuild
deleted file mode 100644
index a86288ff3b73..000000000000
--- a/dev-python/pytest-qt/pytest-qt-4.0.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' python3_{7..9} )
- )
-"
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # This show window test does not work inside the emerge env, as we cannot show windows.
- # pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
- sed -i -e 's:test_wait_window:_&:' tests/test_basics.py || die
-
- # This is not going to work since we want to test both implementations
- # and therefore pull in both and explicitly set PYTEST_QT_API
- sed -i -e 's:test_qt_api_ini_config_with_envvar:_&:' \
- -e 's:test_qt_api_ini_config:_&:' \
- tests/test_basics.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- distutils_install_for_testing
- PYTEST_QT_API="pyqt5" epytest
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- PYTEST_QT_API="pyside2" epytest
- fi
-}
diff --git a/dev-python/pytest-qt/pytest-qt-4.0.1.ebuild b/dev-python/pytest-qt/pytest-qt-4.0.1.ebuild
deleted file mode 100644
index 01570364aa94..000000000000
--- a/dev-python/pytest-qt/pytest-qt-4.0.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="pytest plugin for PyQt5 and PySide2 applications"
-HOMEPAGE="
- https://pypi.org/project/pytest-qt/
- https://github.com/pytest-dev/pytest-qt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
- ' python3_{8..9} )
- )
-"
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # This show window test does not work inside the emerge env, as we cannot show windows.
- # pytestqt.exceptions.TimeoutError: widget <PyQt5.QtWidgets.QWidget object at 0x7f57d8527af8> not activated in 1000 ms.
- sed -i -e 's:test_wait_window:_&:' tests/test_basics.py || die
-
- # This is not going to work since we want to test both implementations
- # and therefore pull in both and explicitly set PYTEST_QT_API
- sed -i -e 's:test_qt_api_ini_config_with_envvar:_&:' \
- -e 's:test_qt_api_ini_config:_&:' \
- tests/test_basics.py || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- virtx python_foreach_impl python_test
-}
-
-python_test() {
- distutils_install_for_testing
- PYTEST_QT_API="pyqt5" epytest
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- PYTEST_QT_API="pyside2" epytest
- fi
-}