summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-07 06:30:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-07 06:43:27 +0200
commit5a731276651073aa2a3fd44b1908d02817283637 (patch)
tree78e465fa9f9225229e0ec64f6a2d16ac99b025f9 /dev-python/pytest-localserver
parentdev-python/python-socks: Bump to 2.5.3 (diff)
downloadgentoo-5a731276651073aa2a3fd44b1908d02817283637.tar.gz
gentoo-5a731276651073aa2a3fd44b1908d02817283637.tar.bz2
gentoo-5a731276651073aa2a3fd44b1908d02817283637.zip
dev-python/pytest-localserver: Bump to 0.9.0_p0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest1
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 634c9fd38131..55f51e1dfd55 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1 +1,2 @@
+DIST pytest_localserver-0.9.0.post0.tar.gz 30280 BLAKE2B fa0a7f410a3a6c0fdda58a2118598dd97e60adc4dfca9474d66d390bc03fb8ac609a7c7ffea5d6f5843ffb6bae57a40749bfa833892188c4943bdd318c9a79ec SHA512 dfab24eb04d25fb725421041d1ac59f449141e996b0810706844df81469a26d2df9679ff4bca9a936c9d865977520d1b2ede6b95c4f8208375c4c679349b8ee5
DIST pytest_localserver-0.9.0.tar.gz 30222 BLAKE2B b452ef71045c8a157035d56a17f1debee15ee63ca3912d44c90e691b744216a2375980f728bb1d33ee41c527c7115ea975299d7d567b23a1ca1c5ce2dcf41dd7 SHA512 15aa2db9d5a9ca841499d455de7002cd2cb6288c165605f44bb88d5ce3e06b9ce02eacd226853734017fe41075e1cfcdd5cd5c422ee240086ef0cf95fc450011
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild
new file mode 100644
index 000000000000..276f8b5374a8
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.9.0_p0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}