summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 06:06:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 07:14:38 +0200
commite28810ce260040a74157b259319b62528bef1578 (patch)
tree0b49f227d7617b1303c91d085decde9f70d1c95a /dev-python/pytest-httpx
parentsys-apps/pkgcore: Fix INSTALL_PREFIX (diff)
downloadgentoo-e28810ce260040a74157b259319b62528bef1578.tar.gz
gentoo-e28810ce260040a74157b259319b62528bef1578.tar.bz2
gentoo-e28810ce260040a74157b259319b62528bef1578.zip
dev-python/pytest-httpx: Bump to 0.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 65a8873eb2cc..1bd9665e993c 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.21.0.gh.tar.gz 23123 BLAKE2B a9a1bc9effc557829071f13cec76aa1d164ae7040b685390c92f33c644c804448eba1ad3e841abdb667a2c0289abd64f5d3633779bd8b0355a1c03d390d94bd5 SHA512 6be6fb39ad1ef233ce9be7cf510422754b6c97a1b565d49224e82cbe4218ee24051b6c5865215ed575f200446dfe8dd1470908467c67077c51a4f5412b113c2a
+DIST pytest-httpx-0.21.1.gh.tar.gz 23997 BLAKE2B feba932cd8a4e7e36cbf98a5c07f8e3264c9f95568568dd4ec4b882a509a4feafd740d3c25a547b7ea28f7e5450083a5f5f7afde0b19bfe46f7999b01565fbe3 SHA512 22cd471996202c78c3d3b433f8ed525e0282df431f0923cfbce42fd543b56a2af20723062773a1a3e3f406a0ce6aa6eed27faaa76731472a903cdad6fb13f771
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
new file mode 100644
index 000000000000..779e7bf2b179
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest