summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-07 21:50:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-07 21:56:44 +0300
commitf4bde1ff63faa11eaafe4d811bd7a4c6f7dac40e (patch)
tree5598aeaaedb09428fbb328dc30b65d281598c852 /dev-python/pytest-codeblocks
parentdev-python/pipenv: add 2022.6.7 (diff)
downloadgentoo-f4bde1ff63faa11eaafe4d811bd7a4c6f7dac40e.tar.gz
gentoo-f4bde1ff63faa11eaafe4d811bd7a4c6f7dac40e.tar.bz2
gentoo-f4bde1ff63faa11eaafe4d811bd7a4c6f7dac40e.zip
dev-python/pytest-codeblocks: add 0.16.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-codeblocks')
-rw-r--r--dev-python/pytest-codeblocks/Manifest1
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.16.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
index 2d57f8afc9bd..512bb993b050 100644
--- a/dev-python/pytest-codeblocks/Manifest
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -1 +1,2 @@
DIST pytest-codeblocks-0.15.0.tar.gz 8559 BLAKE2B 0f8cf91d333e233e480353ab55283f9d97af17e5265f7a9e6db5c7cd98aaf6075b33a44e850aad21de5112fcc233fe7f65e23710f6b1804a85fd6269d042c406 SHA512 57d14aefc0cd49aa1b8fc54dfaec47965d4b1c867cad78ba9e8fd53da85898b7eac303ac402abe10b2d63d7621979bb8bad91f66f1e264568d56f4ff70488021
+DIST pytest-codeblocks-0.16.0.gh.tar.gz 8781 BLAKE2B f6146c78cc8b2bca88533e6a1f18a1abf7af6dc028dc07c37878656b29eb3dc5a838b64791587d9b2888fab00f5ccb2f3c392b7f8d80fbfe7576450e126b1cb3 SHA512 e841ed11c8cd8e73b888bdee3ceda82193e0ed0441d623c586c69c45412039656a09e9f872f187c72d4e245ac8ee99b4a099ed9ae1a13f88f564bc0b9fae69f6
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.0.ebuild
new file mode 100644
index 000000000000..eee40482f02e
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}