summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:59:42 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:06:08 +0200
commitc2a51803c8cdb2494a6e588c43e31432fbd33317 (patch)
tree9fb6862a473148ba5e7b4023b4cfa1663eb11686 /dev-python/pytest-asyncio
parentdev-python/pytools: add 2022.1.1 (diff)
downloadgentoo-c2a51803c8cdb2494a6e588c43e31432fbd33317.tar.gz
gentoo-c2a51803c8cdb2494a6e588c43e31432fbd33317.tar.bz2
gentoo-c2a51803c8cdb2494a6e588c43e31432fbd33317.zip
dev-python/pytest-asyncio: add 0.18.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.18.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 78c43a76ddda..97b892cc0c03 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1 +1,2 @@
DIST pytest-asyncio-0.17.2.tar.gz 23805 BLAKE2B 0501a193518cefb0596b1595a58e8f18915b61ba2b502726b457e78c10b5849e5fc1980192d4b5aceb7499af15556c185efc42b76153e2b8f72ab4e36249ad23 SHA512 f1f6a586a7a3a1672ed76e8758a76e8bd427b0da055461597ab3b6296e3ae50002a9a259aba57f0b6191d606db6fa61377dbf03099d3437272a4a1f4144aa58e
+DIST pytest-asyncio-0.18.2.tar.gz 24515 BLAKE2B d583abe16c215f12a3cc93588d40b9b75188b3a19eb3b4a018551f7fe616e92c73e12c0be6e6a3eadd7357b2396f397013829e1827bf0fc0cb4b96cdd1e64ff4 SHA512 377d219e731ac97a69e143c2de2e327f7293baf4af4bf370cb84dde4f94f705e315bf6deaea4b7d8c1d6cbc54ed753e15ccc0b21a0cef6c3397a560aae684f9e
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.18.2.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.18.2.ebuild
new file mode 100644
index 000000000000..8f3851e525ae
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.18.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/modes/test_legacy_mode.py
+)