summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 18:11:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 18:38:58 +0200
commit98a48b4594216fc856a45c0bf012a28927a7dadd (patch)
tree7383834ff9e0eab10f07afe5f40b06a29db31343 /dev-python/pytest-aiohttp
parentdev-python/ansible-compat: Bump to 4.1.10 (diff)
downloadgentoo-98a48b4594216fc856a45c0bf012a28927a7dadd.tar.gz
gentoo-98a48b4594216fc856a45c0bf012a28927a7dadd.tar.bz2
gentoo-98a48b4594216fc856a45c0bf012a28927a7dadd.zip
dev-python/pytest-aiohttp: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest1
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index 006695422700..271862f283b7 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1 +1,2 @@
DIST pytest-aiohttp-1.0.4.tar.gz 11868 BLAKE2B d964fe29ebe10e80391ebcbe4fc73bf37e2d8568c4d7679493ce68392b5722d75735798a78f388134d60b9c922bac116b0d453cabae5a95fc06c4288cc5d4c8e SHA512 baf87e3aa229e8a4ab6746d277a923436ad2e0625825581c94a2fb0a9bbcd309bfc55186f8866589b65a75ccfd7d5b494d71554359724c0b2c9541ea94a177d8
+DIST pytest-aiohttp-1.0.5.tar.gz 12209 BLAKE2B b02154239a6073bafac3d8be70a7ae8ff13fefdd09941db558c0b1ad31d14c5e29131209f157ab418202852a2d97f151d765cfffe0de06aac57f0c983ea99518 SHA512 b8421c63e4d5caa9742a013a6d1fd3c010b5e4a48e4f5c1a07ddfb7b05853ce6a7a0d65ce78493fd607f59c669d31c75d97a9022048e6a60cbc90a19a48dd02c
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild
new file mode 100644
index 000000000000..a3fd0d0ec5f8
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="
+ https://github.com/aio-libs/pytest-aiohttp/
+ https://pypi.org/project/pytest-aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning doesn't seem to be emitted for some reason
+ # doesn't look very important
+ tests/test_obsolete_fixtures.py::test_loop_fixture
+)