summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 20:32:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 20:32:55 +0200
commitff943fcfc106395e582f6f8132173f6b4879272b (patch)
tree858765f94fca41fc35c5c399580814ea5bd498be /dev-python/pysrt
parentdev-python/networkx: Bump to 3.2.1 (diff)
downloadgentoo-ff943fcfc106395e582f6f8132173f6b4879272b.tar.gz
gentoo-ff943fcfc106395e582f6f8132173f6b4879272b.tar.bz2
gentoo-ff943fcfc106395e582f6f8132173f6b4879272b.zip
dev-python/pysrt: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/pysrt-1.1.2-r1.ebuild18
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild12
2 files changed, 24 insertions, 6 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.2-r1.ebuild b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
index 9c4b2eee378c..3dcd3f63654d 100644
--- a/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
+++ b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
-HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+HOMEPAGE="
+ https://github.com/byroot/pysrt/
+ https://pypi.org/project/pysrt/
+"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
@@ -20,6 +24,14 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/byroot/pysrt/commit/93f52f6d4f70f4e18dc71deeaae0ec1e9100a50f
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 5943e93f9f56..122ca75948b9 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
-HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+HOMEPAGE="
+ https://github.com/byroot/pysrt/
+ https://pypi.org/project/pysrt/
+"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
@@ -20,6 +24,8 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest