summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-11 20:12:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-11 20:12:26 +0200
commit450696ec6ec536ba03ef3fb468790b2953a703da (patch)
tree27da651c647b321148ad903aca2bb320a8de086e /dev-python/pyside2-tools
parentdev-python/pyside2: add 5.15.9 (diff)
downloadgentoo-450696ec6ec536ba03ef3fb468790b2953a703da.tar.gz
gentoo-450696ec6ec536ba03ef3fb468790b2953a703da.tar.bz2
gentoo-450696ec6ec536ba03ef3fb468790b2953a703da.zip
dev-python/pyside2-tools: add 5.15.9
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyside2-tools')
-rw-r--r--dev-python/pyside2-tools/Manifest1
-rw-r--r--dev-python/pyside2-tools/pyside2-tools-5.15.9.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pyside2-tools/Manifest b/dev-python/pyside2-tools/Manifest
index 5fb712c853db..c9a0f9484824 100644
--- a/dev-python/pyside2-tools/Manifest
+++ b/dev-python/pyside2-tools/Manifest
@@ -1 +1,2 @@
DIST pyside-setup-opensource-src-5.15.8.tar.xz 3582256 BLAKE2B eef6668c612c39eac4ea29db4eee0cc6eef72034babaa14525ca63cf6e02695df27bf8a6764110c4bcc77f55c7e9fb531074916a45d7ea324265e50d9a60d592 SHA512 78e19a8e8fa413bb784f16847d5774e4362409a2bd83567177b83f1391c37305d373155fb95ea569c6c483175e62a0d3f5d91a2fd5dae85d48c8047d242b9e22
+DIST pyside-setup-opensource-src-5.15.9.tar.xz 3581660 BLAKE2B 65d5317f9ea55385bbe093cf43c214655effd877feed6409acc4f6f65768dcde8c94c4f29157f8d7dcb36d442c649290764706834885b08ecf9934b383b3e2a4 SHA512 cc63d64b909f1fd98b64a0bba61b278b1a5b60059168287546ee36204ede2df4317eb4ce5638a268d387e6db40fec203631fc4a48e4116a6b4a30d675bf876d3
diff --git a/dev-python/pyside2-tools/pyside2-tools-5.15.9.ebuild b/dev-python/pyside2-tools/pyside2-tools-5.15.9.ebuild
new file mode 100644
index 000000000000..81180b8926ab
--- /dev/null
+++ b/dev-python/pyside2-tools/pyside2-tools-5.15.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{9..11} )
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake python-r1
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="PySide development tools (pyside2-lupdate with support for Python)"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ ~dev-python/pyside2-${PV}[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+# the tools conflict with tools from QT
+PATCHES=(
+ "${FILESDIR}/${PN}-5.15.1-dont-install-tools.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ # The tests are only related to the tools that we don't install
+ local mycmakeargs=(
+ -DBUILD_TESTS=OFF
+ )
+
+ pyside-tools_configure() {
+ local mycmakeargs=(
+ "${mycmakeargs[@]}"
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ )
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
+ }
+
+ python_foreach_impl pyside-tools_configure
+}
+
+src_compile() {
+ pyside-tools_compile() {
+ CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
+ }
+
+ python_foreach_impl pyside-tools_compile
+}
+
+src_install() {
+ pyside-tools_install() {
+ python_doexe "${BUILD_DIR}/pylupdate/pyside2-lupdate"
+ }
+
+ python_foreach_impl pyside-tools_install
+
+ doman pylupdate/pyside2-lupdate.1
+ einstalldocs
+}