summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 14:02:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 14:02:52 +0100
commit37891e01f7540251e02bfdd0899ccd2d38606976 (patch)
treea22ad97bd3a2328539c53b17bacce4ba3f9ceba1 /dev-python/pyrate-limiter
parentdev-python/sexpdata: Bump to 0.0.4 (diff)
downloadgentoo-37891e01f7540251e02bfdd0899ccd2d38606976.tar.gz
gentoo-37891e01f7540251e02bfdd0899ccd2d38606976.tar.bz2
gentoo-37891e01f7540251e02bfdd0899ccd2d38606976.zip
dev-python/pyrate-limiter: Workaround stray file in site-packages
Closes: https://bugs.gentoo.org/893818 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyrate-limiter')
-rw-r--r--dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild36
1 files changed, 25 insertions, 11 deletions
diff --git a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
index 3d5ec115929c..b8c9c6a33c68 100644
--- a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
+++ b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
@@ -9,8 +9,14 @@ PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Python Rate-Limiter using Leaky-Bucket Algorimth Family"
-HOMEPAGE="https://github.com/vutran1710/PyrateLimiter"
-SRC_URI="https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/vutran1710/PyrateLimiter/
+ https://pypi.org/project/pyrate-limiter/
+"
+SRC_URI="
+ https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
S="${WORKDIR}/PyrateLimiter-${PV}"
LICENSE="MIT"
@@ -22,15 +28,17 @@ RDEPEND="
dev-python/redis[${PYTHON_USEDEP}]
"
-BDEPEND="test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/django-redis[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-)"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-redis[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
EPYTEST_DESELECT=(
# Optional dependency redis-py-cluster not packaged
@@ -46,3 +54,9 @@ EPYTEST_DESELECT=(
# dev-python/myst_parser \
# dev-python/sphinxcontrib-apidoc
distutils_enable_tests pytest
+
+src_prepare() {
+ # workaround installing LICENSE into site-packages
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ distutils-r1_src_prepare
+}