summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-29 16:41:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-29 17:20:05 +0200
commit35a7a0a16fee62ecd7bd87b350e4c168f86a2e3d (patch)
treecc719e32a3e71da2a45f76149bd53dbec9bd075a /dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild
parentdev-python/hypothesis: Bump to 6.112.2 (diff)
downloadgentoo-35a7a0a16fee62ecd7bd87b350e4c168f86a2e3d.tar.gz
gentoo-35a7a0a16fee62ecd7bd87b350e4c168f86a2e3d.tar.bz2
gentoo-35a7a0a16fee62ecd7bd87b350e4c168f86a2e3d.zip
dev-python/pyproject-hooks: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild')
-rw-r--r--dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild b/dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild
new file mode 100644
index 000000000000..3853b5b22281
--- /dev/null
+++ b/dev-python/pyproject-hooks/pyproject-hooks-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Wrappers to build Python packages using PEP 517 hooks"
+HOMEPAGE="
+ https://pypi.org/project/pyproject-hooks/
+ https://github.com/pypa/pyproject-hooks/
+ https://pyproject-hooks.readthedocs.io/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails due to setuptools 70.1
+ # https://bugs.gentoo.org/936052
+ # https://github.com/pypa/pyproject-hooks/issues/203
+ tests/test_call_hooks.py::test_setup_py
+)