summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-22 07:10:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-22 08:38:34 +0200
commit121ecfcb9dc78fdae645b1bbc2aa92dc4fd38695 (patch)
treef9b12f4ead6be0431c9df6cb0c09552fc3f6c816 /dev-python/pymongo
parentsys-kernel/installkernel-systemd-boot: no mkdir machineid if using uki (diff)
downloadgentoo-121ecfcb9dc78fdae645b1bbc2aa92dc4fd38695.tar.gz
gentoo-121ecfcb9dc78fdae645b1bbc2aa92dc4fd38695.tar.bz2
gentoo-121ecfcb9dc78fdae645b1bbc2aa92dc4fd38695.zip
dev-python/pymongo: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/pymongo-4.4.0.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 9e12d828bb77..da7c796810e1 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,3 +1,4 @@
DIST mongo-python-driver-4.1.1.tar.gz 1070349 BLAKE2B 9b792343a22c4b0c625376e6f3d10e9c1a88442b63ff2638c29588a26755006507189bf40a8dad96d7f8e4f997efc153c8616826b58114aba32442c05b80ca60 SHA512 b01eb6bc4c39a25cae8350bdc2f37dd5d78da38a6eddbd8a26f91cb6ee067f7b4b1d97eb603defca16e05abc992b8f11b2e3558f9697c99697b3e876838de737
DIST mongo-python-driver-4.2.0.gh.tar.gz 1136734 BLAKE2B b3e2d86780c2874656f94ba3071317c0b9190418274c163135a260cad3f5672b9390aa738d0cf1aaff47412827620706e67c5c990910a5ea232aaacda0758dea SHA512 4439149c35f897a61109b26f5e4c613682ca59727495377a3bbb49f9ff22273cd5a73f58fb55080d07c9403310d4ada59d3a5969d0f76f2f4d1081422fe2dfec
DIST mongo-python-driver-4.3.3.gh.tar.gz 1165202 BLAKE2B e2f442631b1e33353003acde58b9abe49e9f3a0c78f9762d2929c626a1821f04b72e2a55d926703c603c1220124b7334a18b5d35586ebf5b7299720199539e23 SHA512 ba1b344913b6a5d61b0cad05c09b50f5962c5b83e0ca8e8919d76cdde5d2dcec08f38c6f561251c9e199b8878af78bbabaf58af74dc65233e6702ff841ccfef4
+DIST mongo-python-driver-4.4.0.gh.tar.gz 1461533 BLAKE2B 3be9b054bcfeaf7a1c00070b4fc952ab4f0eabce3202dc14a5dd0260a7ead09fd2e15b8f083225b374305e12c29fdb1b0c25238ce8fbb0f055a890fbd22628de SHA512 865c120cf2c79a946226a427a2404d5b38bf1a5e29fb8bc274271ec6715d490281ce208b01e429657d26368baea86775b4b87db405312740e9be39d62fcce88d
diff --git a/dev-python/pymongo/pymongo-4.4.0.ebuild b/dev-python/pymongo/pymongo-4.4.0.ebuild
new file mode 100644
index 000000000000..77c634e1b868
--- /dev/null
+++ b/dev-python/pymongo/pymongo-4.4.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="
+ https://github.com/mongodb/mongo-python-driver/
+ https://pypi.org/project/pymongo/
+"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+IUSE="doc kerberos"
+
+RDEPEND="
+ <dev-python/dnspython-3.0.0[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -e 's:test_service_name_from_kwargs:_&:' \
+ -e 's:test_srv_max_hosts_kwarg:_&:' \
+ -i test/test_client.py || die
+ sed -e '/SRV_SCHEME/s:_HAVE_DNSPYTHON:False:' \
+ -i test/test_uri_spec.py || die
+ # changes in new mypy version
+ sed -e 's:test_mypy_failures:_&:' \
+ -i test/test_typing.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}