summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-04 02:03:32 +0100
committerSam James <sam@gentoo.org>2022-08-04 02:05:14 +0100
commit34468378f3c2a77cb6b40e71f86d4549405041c7 (patch)
treeb355afe6f990fc1e484020d8a6b00726f8d319ed /dev-python/pymilter
parentmail-filter/sigh: depend on libmilter (diff)
downloadgentoo-34468378f3c2a77cb6b40e71f86d4549405041c7.tar.gz
gentoo-34468378f3c2a77cb6b40e71f86d4549405041c7.tar.bz2
gentoo-34468378f3c2a77cb6b40e71f86d4549405041c7.zip
dev-python/pymilter: depend on libmilter
libmilter and sendmail no longer block each other, and we also need a := dep on libmilter. (Straight-to-stable is intentional as long been in stable anyway, but not dropping old w/ git mv or similar yet in case folks want to downgrade to older sendmail for now.) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pymilter')
-rw-r--r--dev-python/pymilter/pymilter-1.0.4-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.4-r3.ebuild b/dev-python/pymilter/pymilter-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..268e99b48bdf
--- /dev/null
+++ b/dev-python/pymilter/pymilter-1.0.4-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="mail-filter/libmilter:="
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests unittest