summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-21 05:07:49 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-21 05:34:26 +0100
commitf5d15080ba03ede1b77aee327eb7b606199713a4 (patch)
tree3bbe8b623a043ff199ef2e531772bbd67bd1e7eb /dev-python/pyglet
parentdev-python/mcbootflash: Bump to 10.1.1 (diff)
downloadgentoo-f5d15080ba03ede1b77aee327eb7b606199713a4.tar.gz
gentoo-f5d15080ba03ede1b77aee327eb7b606199713a4.tar.bz2
gentoo-f5d15080ba03ede1b77aee327eb7b606199713a4.zip
dev-python/pyglet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.1_rc3.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 544e1714620e..75165171fb33 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,4 +1,3 @@
DIST pyglet-2.0.20.gh.tar.gz 6507362 BLAKE2B 43d1d60922f84e05da59ac970516fe33df4a7b86f8b30bb5c7433696d8b2414a2ccd7dbc1c3713f7bd92f1f5ce1c4547e28b65270132f4d7b4f8d4311f1e97ac SHA512 9a628206b758a07eb43efbc4e4d62e25e162885eb25e064a6e0dbfc045472baa57cbebc7c85a9cde0cebe1e3562304878b45f880b51e59c2b226a937da20565f
DIST pyglet-2.0.21.gh.tar.gz 6507374 BLAKE2B a75177b5d6d18b29f48c764d68f89377f11a817bd6d7c5c13f8ea1620e1d9b911127599a9c7ff02ae8b10566724be551dc87f1b8f0105ef938afddb4be4efd5c SHA512 adbfac15fcc75d1dd768ef4af14f15fabef53a69b9f166691d387ebb1ba092170052bc99b254f3596decedcdc7e7880074665177f1821af9fca41e21502b7003
DIST pyglet-2.1.0.gh.tar.gz 6533224 BLAKE2B fed9421ae153f2d117f7ee5b136dab747e84c859383e6e12e5cdac7d9f3fa0476e33762a4a161f46cad087a791007ceba6e80706150a98079d5f2ba96f978128 SHA512 c13ac90600711b134b4770a8cb72e639ed440db79046585139b7ada92f35432b2357204d6d7e95ee457fe921dbce2c384c80a024bb44e7eae2d3ad69543343c8
-DIST pyglet-2.1.rc3.gh.tar.gz 6533959 BLAKE2B adba9ba8d105d832540e2296c0b5de32e8925b12c66cff2645f29a4cf89cc8d4db58ce4e7ed56b6fe1fafaeb1c229d876fceb57058b3367e382c6e751249cfcf SHA512 5a21b04a528aa7b7099af715930d6f81586690a521073716b4628904e44c6f9676cf5444954b15a49d1cea63928a99a95586fd245a95193a8d6f95ddd641e2f8
diff --git a/dev-python/pyglet/pyglet-2.1_rc3.ebuild b/dev-python/pyglet/pyglet-2.1_rc3.ebuild
deleted file mode 100644
index 527153a64f9e..000000000000
--- a/dev-python/pyglet/pyglet-2.1_rc3.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-MY_P=${P/_/.}
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="
- https://pyglet.org/
- https://github.com/pyglet/pyglet/
- https://pypi.org/project/pyglet/
-"
-SRC_URI="
- https://github.com/pyglet/pyglet/archive/v${PV/_/.}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? (
- || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- )
- )
- sound? (
- || (
- media-libs/libpulse
- media-libs/openal
- )
- )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/fontconfig
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- local EPYTEST_DESELECT=(
- # lacking device/server permissions
- tests/unit/media/test_listener.py::test_openal_listener
- tests/unit/media/test_listener.py::test_pulse_listener
- # fragile to system load
- tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
- tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
- )
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}