summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 18:34:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 18:35:21 +0100
commit6c6c5d7698e45a7042963ae649a5fe70aac04cd1 (patch)
treebaf4dd0926309fc10947a7325c8ccf4ebc8122b6 /dev-python/pyformance
parentdev-python/python-neutronclient: Add GH remote-id (diff)
downloadgentoo-6c6c5d7698e45a7042963ae649a5fe70aac04cd1.tar.gz
gentoo-6c6c5d7698e45a7042963ae649a5fe70aac04cd1.tar.bz2
gentoo-6c6c5d7698e45a7042963ae649a5fe70aac04cd1.zip
dev-python/pyformance: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyformance')
-rw-r--r--dev-python/pyformance/pyformance-0.4-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyformance/pyformance-0.4-r2.ebuild b/dev-python/pyformance/pyformance-0.4-r2.ebuild
new file mode 100644
index 000000000000..e13cf4ffb999
--- /dev/null
+++ b/dev-python/pyformance/pyformance-0.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="
+ https://pyformance.readthedocs.org/
+ https://github.com/omergertel/pyformance/
+ https://pypi.org/project/pyformance/
+"
+SRC_URI+="
+ https://dev.gentoo.org/~chutzpah/dist/python/${P}-patches.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${WORKDIR}/${P}-patches"
+)
+
+src_prepare() {
+ sed -e "s/find_packages()/find_packages(exclude=['tests'])/" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}