summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 15:12:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:17:51 +0100
commitc2a939e1e8358592b754d419dfd957773fec4fc6 (patch)
tree8ec645bd07c4c67021d20f201b4b0c5afebd19cd /dev-python/proto-plus
parentdev-python/google-api-core: Remove Python < 3.10 (diff)
downloadgentoo-c2a939e1e8358592b754d419dfd957773fec4fc6.tar.gz
gentoo-c2a939e1e8358592b754d419dfd957773fec4fc6.tar.bz2
gentoo-c2a939e1e8358592b754d419dfd957773fec4fc6.zip
dev-python/proto-plus: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild b/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild
new file mode 100644
index 000000000000..a97f156bb73d
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme