summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-18 19:11:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-18 19:11:25 +0200
commitba5547f08fcbeb6e8e44a1b3b04e077f8fef8769 (patch)
treeabb82ee7ace9c7f509f69c08efd2973d88b9d1b6 /dev-python/poetry-core
parentdev-python/pytest-httpserver: Remove old (diff)
downloadgentoo-ba5547f08fcbeb6e8e44a1b3b04e077f8fef8769.tar.gz
gentoo-ba5547f08fcbeb6e8e44a1b3b04e077f8fef8769.tar.bz2
gentoo-ba5547f08fcbeb6e8e44a1b3b04e077f8fef8769.zip
dev-python/poetry-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest2
-rw-r--r--dev-python/poetry-core/poetry-core-1.5.2.ebuild64
-rw-r--r--dev-python/poetry-core/poetry-core-1.6.0.ebuild75
3 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index ad4523de67f5..60c77ada3bf6 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,3 +1 @@
-DIST poetry-core-1.5.2.gh.tar.gz 484004 BLAKE2B 56fe974bb37233ee75a220d35dab3d246b9a4145a3abd88981a0c2b9f51cb894b3534746638d7fa75a41451c856261b0b8e737af8778f78fcc9ae894a4b2430f SHA512 e0eab97bcf678f8fd329074d14cb394db8732666b0387384d273db49ec020ff34e15e9982e049bce62e9ba80443404de7646e66433164a2358f9802a8ce2fbb1
-DIST poetry-core-1.6.0.gh.tar.gz 476282 BLAKE2B 9c78b60b0578c9e882c468d8523587e8ddf799764efc1d343fdbcbc7e1ac56cc642ecfa5e74a6b134d190491e06105579951fd4bc8d41264358032c2a6bd5fb7 SHA512 a8a36feda81fdf5b74de77cb718680a12edda44d0b6e87f5b80704d7a5898780b89dfa8168c55e4e8b2352f1a6051072e7e9f35dc5936d1b0b24a1704063ed1d
DIST poetry-core-1.6.1.gh.tar.gz 477291 BLAKE2B 4e1bd77302005d344693fe7a08b0c55e8a9ea0aad3112915a18950e40cc51116740b9eff5ae851b1d7280454716e3a86b1d8d37d85749f64fcef3bc726eeaf83 SHA512 53db0e4f4d5bc6ed2b201cd88a84e07dc6421e910292b8b5efb0dcce1af6e8c62836458a6409aac0394b5063b7c4a6be93784b0bce8592d74f61800f54916706
diff --git a/dev-python/poetry-core/poetry-core-1.5.2.ebuild b/dev-python/poetry-core/poetry-core-1.5.2.ebuild
deleted file mode 100644
index c31020c84fcd..000000000000
--- a/dev-python/poetry-core/poetry-core-1.5.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Poetry PEP 517 Build Backend"
-HOMEPAGE="
- https://github.com/python-poetry/poetry-core/
- https://pypi.org/project/poetry-core/
-"
-SRC_URI="
- https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# check inside src/poetry/core/_vendor/vendor.txt
-# (note that some are indirect deps)
-RDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # These "fail" bacause of glob file path resulting from newer versions
- # in our tree than vendored. But those don't affect anything.
- tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
- tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
-)
-
-src_prepare() {
- # remove vendoring of dependencies
- rm -r src/poetry/core/_vendor || die
- sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # needed for migration from <1.1
- distutils_write_namespace poetry
- epytest
-}
diff --git a/dev-python/poetry-core/poetry-core-1.6.0.ebuild b/dev-python/poetry-core/poetry-core-1.6.0.ebuild
deleted file mode 100644
index fdc7a6e8c35a..000000000000
--- a/dev-python/poetry-core/poetry-core-1.6.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_TESTED=( pypy3 python3_{10..12} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1
-
-DESCRIPTION="Poetry PEP 517 Build Backend"
-HOMEPAGE="
- https://github.com/python-poetry/poetry-core/
- https://pypi.org/project/poetry-core/
-"
-SRC_URI="
- https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# check inside src/poetry/core/_vendor/vendor.txt
-# (note that some are indirect deps)
-RDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- $(python_gen_cond_dep '
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-vcs/git
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # These "fail" bacause of glob file path resulting from newer versions
- # in our tree than vendored. But those don't affect anything.
- tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
- tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
-)
-
-src_prepare() {
- # remove vendoring of dependencies
- rm -r src/poetry/core/_vendor || die
- sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skippin tests on ${EPYTHON} (unported deps)"
- return
- fi
-
- # needed for migration from <1.1
- distutils_write_namespace poetry
- epytest
-}