summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 13:19:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 13:33:07 +0200
commiteb349eb32b2b1247abf28fa6aaba85781d7eb033 (patch)
tree0d195b2b77744db3356802fb715f891bc61b4a0f /dev-python/podman
parentdev-python/plotly: Remove old (diff)
downloadgentoo-eb349eb32b2b1247abf28fa6aaba85781d7eb033.tar.gz
gentoo-eb349eb32b2b1247abf28fa6aaba85781d7eb033.tar.bz2
gentoo-eb349eb32b2b1247abf28fa6aaba85781d7eb033.zip
dev-python/podman: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest1
-rw-r--r--dev-python/podman/podman-4.4.0.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
index 809763821654..4c216727c79f 100644
--- a/dev-python/podman/Manifest
+++ b/dev-python/podman/Manifest
@@ -1,2 +1 @@
-DIST podman-py-4.4.0.gh.tar.gz 177587 BLAKE2B 92d2a45a20304be648247fe8c95ab7ed84795e419d79fc731a6be4f228851b10324546b9cd14f9235a3972fd9258d50b2512216121c0fef59c0eb66d7c12c91c SHA512 47b4157fd9e6d54171f6f970012e828f877c66c4fabe4f30ad93974945b9e35fa7084c2908efca42c8b71a8d9f25e7a29a624152ce7bea1eebafcaa3700cb967
DIST podman-py-4.5.0.gh.tar.gz 179025 BLAKE2B 6725bd79a5fb0a17a75080b323cf62b56a3ef83d20c7113364785e0994a053455a08d9ffb2bbbbfb646fb730367de9bfd838c7eb92053a93a55008c59ec59732 SHA512 903466e11afebd26da65cc363ab49a56255731ea8bc07d202dd80907e1dd6704b5a8542c5a417f3c46ec93882bb21ef6990ae80fe558dfd3310b9272590cbd39
diff --git a/dev-python/podman/podman-4.4.0.ebuild b/dev-python/podman/podman-4.4.0.ebuild
deleted file mode 100644
index 843534a57bf8..000000000000
--- a/dev-python/podman/podman-4.4.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=podman-py-${PV}
-DESCRIPTION="A library to interact with a Podman server"
-HOMEPAGE="
- https://github.com/containers/podman-py/
- https://pypi.org/project/podman/
-"
-SRC_URI="
- https://github.com/containers/podman-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
- )
-
- # integration tests require a workable podman server,
- # and it doesn't seem to work in ebuild env
- epytest podman/tests/unit
-}