summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-22 09:03:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-22 09:30:11 +0100
commitaf011901c185843f97c7f96e7be116967229324a (patch)
tree2a41423db2eba3b456efa0d75617f9a7ac3e87e5 /dev-python/podman
parentdev-python/nbconvert: Bump to 7.13.1 (diff)
downloadgentoo-af011901c185843f97c7f96e7be116967229324a.tar.gz
gentoo-af011901c185843f97c7f96e7be116967229324a.tar.bz2
gentoo-af011901c185843f97c7f96e7be116967229324a.zip
dev-python/podman: Bump to 4.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest1
-rw-r--r--dev-python/podman/podman-4.8.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
index 5c8ef6d6fb10..9a65f89d1a07 100644
--- a/dev-python/podman/Manifest
+++ b/dev-python/podman/Manifest
@@ -2,3 +2,4 @@ DIST podman-py-4.5.0.gh.tar.gz 179025 BLAKE2B 6725bd79a5fb0a17a75080b323cf62b56a
DIST podman-py-4.6.0.gh.tar.gz 180393 BLAKE2B bb5e32cc57d3e545e28f98857ecdc643aed7eb208b12e14d0bbf961ec4ac115ee709af88e8f541fd2b73aab1c319d10f7835319dacadb52813e05820348c8406 SHA512 4d60d3643e679d68f560988c2b31272703059dc000e6361b44d896df480a72f36df595f0122ee39f44874b76a7286bbf05ea8c045e5afa58bd0c7b0a5a42f2de
DIST podman-py-4.7.0.gh.tar.gz 181261 BLAKE2B 039ef411ce365d7bec18b9ba5964e149ed5ca437af3640361d9bf4e9ff96f2c9fbe5cf538e547612d7dcdf132045a71bb1e4bd93124b16d4bc7ff46c9d5c5a0a SHA512 c570ce3e7e11cd2f78a80ccfe43ef1fbf3fd7d96f2d93b92cc50284da15361c9d786f82602d696400f92e5a72bba8f85e9d9184182df1d09c9fee2523169e6cc
DIST podman-py-4.8.0.post1.gh.tar.gz 182168 BLAKE2B e4c310cdf224f39c75337b9b87dcee2449460a44d4e1e42e30fe3289d47054cb1431e21c92b2c0ce6f14a9121c3adb7a87d569e0989e613078b63b978ea1246a SHA512 9908b0ae23706b9455f8bb56491f67a411c4209e1bb64d05152f7c7b07e59590e200d3f0ebeedb56f7425861d77ca3a00579aa7a18cd09791d372409c1aeff4f
+DIST podman-py-4.8.1.gh.tar.gz 182099 BLAKE2B 345cf5374baeab6760dd0494a105963658a3c0cff5a8e283be7ac7e6f8f9acba742022628cfde7f978d08f99a680b2c4aebd1d5682553b3bd0f5609d3265c93d SHA512 35f62f16f61ec0a5ebfeede0e6e8fe5528b896315e000529a0aff38bf572b3b558e5066f034ba38a755899e1b6a7a26623406c677a6c7f3aad777094377b5755
diff --git a/dev-python/podman/podman-4.8.1.ebuild b/dev-python/podman/podman-4.8.1.ebuild
new file mode 100644
index 000000000000..dc5cb958dc37
--- /dev/null
+++ b/dev-python/podman/podman-4.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=podman-py-${PV/_p/.post}
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/
+"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}