summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-22 21:23:33 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-22 21:23:33 +0200
commit53c00c6a68e5141970e27b9523cdde3ede008a76 (patch)
treee94daa4ad6ee75fbd4c76e98515aea9270d9b27d /dev-python/pockets
parentdev-python/flit: enable py3.11 (diff)
downloadgentoo-53c00c6a68e5141970e27b9523cdde3ede008a76.tar.gz
gentoo-53c00c6a68e5141970e27b9523cdde3ede008a76.tar.bz2
gentoo-53c00c6a68e5141970e27b9523cdde3ede008a76.zip
dev-python/pockets: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pockets')
-rw-r--r--dev-python/pockets/pockets-0.9.1-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pockets/pockets-0.9.1-r3.ebuild b/dev-python/pockets/pockets-0.9.1-r3.ebuild
new file mode 100644
index 000000000000..2bcaaa2a11bb
--- /dev/null
+++ b/dev-python/pockets/pockets-0.9.1-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+# No tags upstream, https://github.com/RobRuana/pockets/issues/5
+COMMIT="777724c8eabaf76f6d0c5e4837c982d110509b2e"
+
+DESCRIPTION="Collection of helpful Python tools"
+HOMEPAGE="https://pockets.readthedocs.io/ https://pypi.org/project/pockets/"
+SRC_URI="
+ https://github.com/RobRuana/pockets/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's/description-file/description_file/g' -i setup.cfg ||die
+ default
+}