summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 18:26:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 18:27:02 +0200
commit3b0d50246b85693410c283e978931f3c71d49f52 (patch)
tree5a8b8d5c6f271f56637aae83b957001341c478e0 /dev-python/platformdirs
parentdev-python/hatch-vcs: New package, v0.2.0 (diff)
downloadgentoo-3b0d50246b85693410c283e978931f3c71d49f52.tar.gz
gentoo-3b0d50246b85693410c283e978931f3c71d49f52.tar.bz2
gentoo-3b0d50246b85693410c283e978931f3c71d49f52.zip
dev-python/platformdirs: Bump to 2.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-2.5.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 94fc54d292c4..7b40886a312d 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1 +1,2 @@
DIST platformdirs-2.5.1.gh.tar.gz 20103 BLAKE2B 78df153feabd397e6ab0d3c5edfe899f2e2685e7b287bd17c36346bc109d90ba783b5164605bda448322811312299ce65d49b85537ebd1629448c1d82f4718e5 SHA512 c0f3e79fbb41cda1f543fcb6d3a4ea0c96872d195197aa720864c1ed0efa095e633202878da9b19abfb2aded08f5c736f431b1c615ee0f21cbf1775e87b12356
+DIST platformdirs-2.5.2.gh.tar.gz 20335 BLAKE2B 5d11e39d3e7482646e90d57642f0a956633408de5ec9f3cc1954e451ebb3bc3234a453c1e62997bcc74a32082f5d044a1e68ef6d7e75e27876495ad6ffb3c8f5 SHA512 7162050adff66124601359f0c1f73e671444d286e9f00c2694647df233c25e1eae673baf829e3e74e2a54d15a1633d0202dba986d4ed8a2864fc47859af0fd4e
diff --git a/dev-python/platformdirs/platformdirs-2.5.2.ebuild b/dev-python/platformdirs/platformdirs-2.5.2.ebuild
new file mode 100644
index 000000000000..475252c18028
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}