summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 06:25:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:03 +0200
commitdabe4aae905043bccd66e8fb85979b8d9775121c (patch)
tree7cb7972545e07c2b3c8f688b1249425a42166a60 /dev-python/pgspecial
parentapp-admin/awscli: Bump to 1.25.12 (diff)
downloadgentoo-dabe4aae905043bccd66e8fb85979b8d9775121c.tar.gz
gentoo-dabe4aae905043bccd66e8fb85979b8d9775121c.tar.bz2
gentoo-dabe4aae905043bccd66e8fb85979b8d9775121c.zip
dev-python/pgspecial: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-2.0.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 1ab608246aad..1e1b19bac4bf 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,2 +1,3 @@
DIST pgspecial-1.13.1.tar.gz 50269 BLAKE2B 0566a7c2d8ee1ea350e27a4283f56c4cb1360f23ac9fe0147358ff68f527907c47650466dd41ae9c68e8a1f8ba658e452a88db360a7066f5562b7f0c578b8b62 SHA512 4b8f0495451db40087327640edc4bf8c29997b4f501dc5af6d093ad880fc337050d651676ae8ff434da3564e773f9e89e6e7d6bf0d6cfb7b70d8b4beea73a347
DIST pgspecial-2.0.0.gh.tar.gz 50098 BLAKE2B 3e4c2b85c8d0e31bdd6d61fd1dd8e9a54b68fef23017e2a11238018d63fff8ba93ee5f8f5f4679321b1a757b4a504d86d9740bea91c95f0312a31cf0135378fa SHA512 59dfbc83be3f263fdf9fdad425675624f2738357f2b3f29abc37b90df1bdae30bee6145faa65715a7a166a9e8ee66201cc5344e697ce0121ae7c6bf9bb3af012
+DIST pgspecial-2.0.1.gh.tar.gz 50181 BLAKE2B 6f3f9f8feba717c18d3985d80a432eb7d127c65f7436bfc792a44cb5d7aad08e6e3b931cc289a051fbfea43cd5d8d7db44ede6de89683d462d51635c5caf2e04 SHA512 e89e7cd0f7e849fe93b8e8e79e409ee73ba6c22f3d76279415f236184f732d12cdd8b6bb7722b24ec2bd665f3429c0bf4e6905cd24c9739aa78906b12f841f13
diff --git a/dev-python/pgspecial/pgspecial-2.0.1.ebuild b/dev-python/pgspecial/pgspecial-2.0.1.ebuild
new file mode 100644
index 000000000000..3873d4fe47e4
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-2.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="
+ https://github.com/dbcli/pgspecial/
+ https://pypi.org/project/pgspecial/
+"
+SRC_URI="
+ https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( License.txt README.rst changelog.rst )
+
+src_test() {
+ local db=${T}/pgsql
+
+ initdb --username=postgres -D "${db}" || die
+ # TODO: random port
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U postgres -d postgres \
+ -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U postgres _test_db || die
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}