summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:27:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:21 +0100
commitd43d8153f526c42de9a09c10ae0a665f2e1087a2 (patch)
tree0e2e3855250d5835498a749bb30da445b7093683 /dev-python/pdm-pep517
parentdev-python/markdown: Bump to 3.4.3 (diff)
downloadgentoo-d43d8153f526c42de9a09c10ae0a665f2e1087a2.tar.gz
gentoo-d43d8153f526c42de9a09c10ae0a665f2e1087a2.tar.bz2
gentoo-d43d8153f526c42de9a09c10ae0a665f2e1087a2.zip
dev-python/pdm-pep517: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdm-pep517')
-rw-r--r--dev-python/pdm-pep517/Manifest1
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.1.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pdm-pep517/Manifest b/dev-python/pdm-pep517/Manifest
index 3ee06f10b8f3..8361ad5747de 100644
--- a/dev-python/pdm-pep517/Manifest
+++ b/dev-python/pdm-pep517/Manifest
@@ -1 +1,2 @@
DIST pdm-pep517-1.1.2.gh.tar.gz 231983 BLAKE2B b2225da24f52d4d2c1a903db57f000a1fb2ba8435083d956ff740d272ee2fa8f00cf001673e32800fc0437ae2d1016cac661fda24f8b5f34c83a342fd3e8c353 SHA512 8f6140492ef8323044f01887895e6664019092f964e1fae3a829bcefb3d5d9c9223ef163183899681270f95b4a3a517951b7e44629ec3f37598c04ccbb221cac
+DIST pdm-pep517-1.1.3.gh.tar.gz 232038 BLAKE2B 8d7e4cbd439c8cd5fd541043da93fcee4737d47c27ce049743c0944bff66b4784b00e3650e088e1ddfabcdfd4398e5fe90f3029a8353d91cc4b11ec8625d44eb SHA512 ed29b2c5a2030ceb103eb9df3d399efa316c02fb97b2000d770591c9f1abe0adeabf1cbdb9b5863dc82a1adfb67dd6385c362963145779fbf63dd39e0ff533f0
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.1.3.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.1.3.ebuild
new file mode 100644
index 000000000000..0e5c54867e4a
--- /dev/null
+++ b/dev-python/pdm-pep517/pdm-pep517-1.1.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+# upstream has renamed the repo but the legacy branch is still published
+# as pdm-pep517, sigh
+MY_P=pdm-backend-${PV}
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-pep517/
+ https://github.com/pdm-project/pdm-backend/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-backend/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r pdm/pep517/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.pep517\._vendor\.:from :' \
+ -e 's:from pdm\.pep517\._vendor ::' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}