summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-19 15:56:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-19 17:18:14 +0300
commit56e11c1f7a3b02cb5b0146f9e44e01242fe59ecf (patch)
treeb9dbdf9c6f7c919aa12c6a89f8b1f880cb1a0f98 /dev-python/paste
parentdev-python/boto3: add 1.24.55 (diff)
downloadgentoo-56e11c1f7a3b02cb5b0146f9e44e01242fe59ecf.tar.gz
gentoo-56e11c1f7a3b02cb5b0146f9e44e01242fe59ecf.tar.bz2
gentoo-56e11c1f7a3b02cb5b0146f9e44e01242fe59ecf.zip
dev-python/paste: add 3.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.5.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index e21b78bba635..784f0c2a192b 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.5.1.tar.gz 637755 BLAKE2B fc5f4afc064ced52322f7c2cb20c84d24538bdd3a5dadf7b47f62dd8b64ed62a2925102b785e366bc9b9257835529ae226a4d291bebd40d70bda16be781613c6 SHA512 7ae39691bb6067309a12bf76e2a110913c7be6ddcda6215eaf0228144ff26a1c7b50500729b65e27652dc7a7edf6fe26bd144d261e8754d7af8bac495d4613f9
+DIST Paste-3.5.2.tar.gz 638207 BLAKE2B 98d9f508923836e41657b653b1cd70d3cea13121dee375c6cfaf28e6f82ebcc36ba74658ade927fd6802f09bf9d9ca566d2b9bbf3eed5122aedd35ed0ac9d5ec SHA512 a1920dbd7ebea137ca33f8f8c33aad563329d1eea193d84e6aa7fc57690f706c1969e3ba76bbf21a73c59a0fe0f732daa4db15705914ac359814b4332a01bc75
diff --git a/dev-python/paste/paste-3.5.2.ebuild b/dev-python/paste/paste-3.5.2.ebuild
new file mode 100644
index 000000000000..7b27623d9a37
--- /dev/null
+++ b/dev-python/paste/paste-3.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/cdent/paste/
+ https://pypi.org/project/Paste/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-paste
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to cgi deprecation warning
+ tests/test_cgiapp.py::test_form
+ )
+
+ epytest
+}