summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-05 10:25:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-05 10:25:51 +0300
commit41058480dd2de8d25b5ab6055543cd5ed4b23a54 (patch)
tree2eeda7b0103ea319feed2c59079d0d8e7de39415 /dev-python/ovs/ovs-2.17.1_p1.ebuild
parentdev-python/autobahn: add 22.4.2 (diff)
downloadgentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.tar.gz
gentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.tar.bz2
gentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.zip
dev-python/ovs: add 2.17.1_p1, enable py3.10, cleanup
Closes: https://bugs.gentoo.org/841569 Closes: https://bugs.gentoo.org/722582 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ovs/ovs-2.17.1_p1.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.17.1_p1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.17.1_p1.ebuild b/dev-python/ovs/ovs-2.17.1_p1.ebuild
new file mode 100644
index 000000000000..f0cef5068684
--- /dev/null
+++ b/dev-python/ovs/ovs-2.17.1_p1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+
+DESCRIPTION="OVS bindings for python"
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"