summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 12:46:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 12:46:09 +0200
commitf328b711afbc5bf94ccc0b398e4a5bab8b9021ac (patch)
tree3a27d97961f8d98cb8712f4c6290a796738fc401 /dev-python/openapi-core
parentdev-python/google-api-python-client: Remove old (diff)
downloadgentoo-f328b711afbc5bf94ccc0b398e4a5bab8b9021ac.tar.gz
gentoo-f328b711afbc5bf94ccc0b398e4a5bab8b9021ac.tar.bz2
gentoo-f328b711afbc5bf94ccc0b398e4a5bab8b9021ac.zip
dev-python/openapi-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.17.1.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 2cc9579d57a4..83fef7a1653a 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,4 +1,3 @@
DIST openapi-core-0.16.6.gh.tar.gz 104008 BLAKE2B bb1bdac98dfc5aef0961624488074363568f53a6c44cb0730be0d103d891d24bed86659f640e0d07da4072edc233c904c0ddcfd9e8b3960ace1af078c0d745e5 SHA512 556636a4698dcd7db6c656333849077abacdac1a440fe58210ad8f02c1f0220e46dea29962346dfb3f89d164ebc986ec750c184840be9a34a5e1dd98fbf8ef98
-DIST openapi_core-0.17.1.tar.gz 85686 BLAKE2B f18b42fc496eaf4d6b82c15f66dd9c2eb9240402590b5a8e1f0e7b1e804c90aeef2db96d19683e9fea5846e776e95981ac52a38c47e2b56e6b5fd63d072b61f7 SHA512 0e2c673dbbfcce87ae7fbca6ec6c283d94c36376b1e17191d0bfa6c7001c62913381169b4614b5cd6131eaa67b729365036be3f1eb7641f634c0f3228de54897
DIST openapi_core-0.17.2.tar.gz 88262 BLAKE2B 4d9a1be1eff4118bc1c687e57af0ff3738f984ceb6e564c643d26cb795bbcd3e703dd22c3b45d574f498d290f8da225819c9df618da5a1b8e40758304f2ebd07 SHA512 73cd2b62149549bd56781adb44922bca4a0519fbae8b6539d0225799ba1cfa1ab584428fd572ee42af4731b5437f08b8c4ad8f8895444aef315e4c6909fd4e5a
DIST openapi_core-0.18.0.tar.gz 83474 BLAKE2B 785e95969e03d9ccf17e40c7ce563cef6ab45c417e397b0f03e982622fb1c65d4b3e719e94e1072c7a41b837097efea7b83e29e8ceec64579f1c58040c9fb291 SHA512 d9e516e00a53937f79c7419823a1533a507731e20da36e1186a1800f713154135524db968483ce850bd9a90a4c322ca1c957d6a7f99e9d8eefdc244ed9ce8bc0
diff --git a/dev-python/openapi-core/openapi-core-0.17.1.ebuild b/dev-python/openapi-core/openapi-core-0.17.1.ebuild
deleted file mode 100644
index 1db135f6e88e..000000000000
--- a/dev-python/openapi-core/openapi-core-0.17.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.4.2[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/asgiref[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}