summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-12 18:35:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-12 19:14:20 +0200
commit3502841473ef8cf94ef14e47449863bbd37f4b5d (patch)
tree5317a81cabecbc160009b7e758d49bfa2ab1c34e /dev-python/noseofyeti
parentrust-toolchain.eclass: Drop unused rust_all_abis() and multilib inherit (diff)
downloadgentoo-3502841473ef8cf94ef14e47449863bbd37f4b5d.tar.gz
gentoo-3502841473ef8cf94ef14e47449863bbd37f4b5d.tar.bz2
gentoo-3502841473ef8cf94ef14e47449863bbd37f4b5d.zip
dev-python/noseofyeti: Stop installing .pth file
Stop installing the .pth file as we do not need it, and it breaks builds of dev-lang/python (sigh!). Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/noseofyeti')
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.9-r1.ebuild (renamed from dev-python/noseofyeti/noseofyeti-2.4.9.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.9.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.9-r1.ebuild
index aa6f56d6b284..47214fbcd460 100644
--- a/dev-python/noseofyeti/noseofyeti-2.4.9.ebuild
+++ b/dev-python/noseofyeti/noseofyeti-2.4.9-r1.ebuild
@@ -31,3 +31,9 @@ EPYTEST_DESELECT=(
# requires alt-pytest-asyncio
tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
)
+
+src_install() {
+ distutils-r1_src_install
+ # delete the black .pth thingy, it breaks building CPython (sigh!)
+ find "${ED}" -name '*.pth' -delete || die
+}