summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-27 11:57:41 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-27 12:07:19 +0100
commitbdff536f0ebb46c62377f9c49448dfe30d3d4359 (patch)
tree2f0844e5c9584b5604e06db19b51f78bb5cc29e5 /dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
parentdev-python/blessings: treeclean (diff)
downloadgentoo-bdff536f0ebb46c62377f9c49448dfe30d3d4359.tar.gz
gentoo-bdff536f0ebb46c62377f9c49448dfe30d3d4359.tar.bz2
gentoo-bdff536f0ebb46c62377f9c49448dfe30d3d4359.zip
dev-python/ndg-httpsclient: treeclean
Closes: https://bugs.gentoo.org/888147 Closes: https://bugs.gentoo.org/705116 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
deleted file mode 100644
index a7a07d13c1b7..000000000000
--- a/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
-HOMEPAGE="
- https://github.com/cedadev/ndg_httpsclient/
- https://pypi.org/project/ndg-httpsclient/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
-S="${WORKDIR}/${P/-/_}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]"
-# we need to block the previous versions since incorrect namespace
-# install breaks tests
-BDEPEND="
- test? (
- !!<dev-python/ndg-httpsclient-0.4.2-r1
- dev-libs/openssl:0
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-expiration-test-fix.patch"
-)
-
-distutils_enable_tests unittest
-
-src_test() {
- # we need to start a fake https server for tests to connect to
- ( cd ndg/httpsclient/test && sh ./scripts/openssl_https_server.sh ) &
- local server_pid=${!}
-
- distutils-r1_src_test
-
- kill "${server_pid}"
- wait
-}