summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 11:19:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-03 12:30:01 +0200
commitf993ee1530f0daf11cda5b19be4ebbce1e967ebd (patch)
tree9bd3884962dd3ddcdacd897746b104e57a6c6aa9 /dev-python/nbsphinx
parentdev-python/libsass: add py3.10 (diff)
downloadgentoo-f993ee1530f0daf11cda5b19be4ebbce1e967ebd.tar.gz
gentoo-f993ee1530f0daf11cda5b19be4ebbce1e967ebd.tar.bz2
gentoo-f993ee1530f0daf11cda5b19be4ebbce1e967ebd.zip
dev-python/nbsphinx: Bump to 0.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.6.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index 5424cc95d091..09eb35176e51 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1,2 +1,3 @@
DIST nbsphinx-0.8.4.tar.gz 142976 BLAKE2B 953c74e5d90a8a304c30334b15409b4d50b3aa4560c7669bcde6526529041b1088cd51ba66573ef3ff9e24843550ed42080c6f6bddc1022d2e1ce59d4e3ad914 SHA512 4e644c02661440f0705a792655c35e1789e2ef051ec24b538e7ddcfb68024063b60a742efc67afbe7578eb3a3b1880a284e8710d08de4c014e46ea34c48dbdf5
DIST nbsphinx-0.8.5.tar.gz 145770 BLAKE2B 734ce1081aa18b670f15d00b79930af5fac8a531a9a6d645ad903fcea537cd95561f41360c3028a60503bf878aff0d7105a0a753563ae5bb70ccb68db118e761 SHA512 1fdb52741e01afc7e3a67d97d3edee14b5270a3404da607c97c116b839ba23c641b2d3e338df81db52bd677d71861c62dcc08184ef92165d6a53a6841c1a96e5
+DIST nbsphinx-0.8.6.tar.gz 146019 BLAKE2B 106c121e9306c1b79771d49697f125b7c9272bddd9859b308d272e69cccf38fa306330bac01e8744f1a5a1e6831f63b73b43b0a2260eacceee4d2ff6c4ae61ef SHA512 11ff82be0633b3a2af2238d9dfe4406900804caf494885a5b3ff22f651c8c43000dadf83546ffaa85873901ef9625c2e786e53e866c27141fd9e9d58927ebf14
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.6.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.6.ebuild
new file mode 100644
index 000000000000..94b3df799087
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]"