summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-14 21:03:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-14 21:06:08 +0200
commitab84b003ad8405976235aa748b9c2678db890745 (patch)
tree58c9652c5281e69cba1a864c12d51ef36e7b6fc9 /dev-python/munch
parentdev-python/mistletoe: Enable py3.13 (diff)
downloadgentoo-ab84b003ad8405976235aa748b9c2678db890745.tar.gz
gentoo-ab84b003ad8405976235aa748b9c2678db890745.tar.bz2
gentoo-ab84b003ad8405976235aa748b9c2678db890745.zip
dev-python/munch: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/munch')
-rw-r--r--dev-python/munch/files/munch-4.0.0-py313.patch29
-rw-r--r--dev-python/munch/munch-4.0.0.ebuild9
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/munch/files/munch-4.0.0-py313.patch b/dev-python/munch/files/munch-4.0.0-py313.patch
new file mode 100644
index 000000000000..6d7cba2b89d7
--- /dev/null
+++ b/dev-python/munch/files/munch-4.0.0-py313.patch
@@ -0,0 +1,29 @@
+From 84651ee872f9ea6dbaed986fd3818202933a8b50 Mon Sep 17 00:00:00 2001
+From: Karolina Surma <ksurma@redhat.com>
+Date: Wed, 5 Jun 2024 09:49:49 +0200
+Subject: [PATCH] Adjust tests for Python 3.13
+
+---
+ tests/test_munch.py | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/tests/test_munch.py b/tests/test_munch.py
+index c80b757..5886fdd 100644
+--- a/tests/test_munch.py
++++ b/tests/test_munch.py
+@@ -225,6 +225,15 @@ def test_reserved_attributes(attrname):
+ assert attr == 'munch'
+ elif attrname == '__dict__':
+ assert attr == {}
++ elif attrname == '__static_attributes__':
++ # Python 3.13: added __static_attributes__ attribute, populated by the
++ # compiler, containing a tuple of names of attributes of this class
++ # which are accessed through self.X from any function in its body.
++ assert isinstance(attr, tuple)
++ elif attrname == '__firstlineno__':
++ # Python 3.13: added __firstlineno__ attribute, populated by the
++ # compiler, containing the line number of the first line of the class definition
++ assert isinstance(attr, int)
+ else:
+ assert callable(attr)
+
diff --git a/dev-python/munch/munch-4.0.0.ebuild b/dev-python/munch/munch-4.0.0.ebuild
index 5e000b9f640e..00bee963b931 100644
--- a/dev-python/munch/munch-4.0.0.ebuild
+++ b/dev-python/munch/munch-4.0.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -26,3 +26,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Infinidat/munch/pull/104
+ "${FILESDIR}/${P}-py313.patch"
+)