summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:09:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:09:47 +0300
commit27357a3edaae197b2eeaf2a2f3e4c5eee4468862 (patch)
tree9f0bd826dff51a993290debe05a7e22a731b07e8 /dev-python/mmtf-python/mmtf-python-1.1.3.ebuild
parentsys-process/glances: add myself as a maintainer (diff)
downloadgentoo-27357a3edaae197b2eeaf2a2f3e4c5eee4468862.tar.gz
gentoo-27357a3edaae197b2eeaf2a2f3e4c5eee4468862.tar.bz2
gentoo-27357a3edaae197b2eeaf2a2f3e4c5eee4468862.zip
dev-python/mmtf-python: add 1.1.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mmtf-python/mmtf-python-1.1.3.ebuild')
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild
new file mode 100644
index 000000000000..ae3761f68a55
--- /dev/null
+++ b/dev-python/mmtf-python/mmtf-python-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="http://mmtf.rcsb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" mmtf/tests/codec_tests.py -v || die "Tests failed with ${EPYTHON}"
+}